SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers
☆20Jul 9, 2023Updated 3 years ago
Alternatives and similar repositories for ocaml-socks
Users that are interested in ocaml-socks are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Basic password manager library and command-line application in OCaml☆12Mar 14, 2018Updated 8 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- ☆11Apr 22, 2016Updated 10 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 5 years ago
- Library to provide session types to allow for static verification of protocols between concurrent computations.☆17Jan 1, 2017Updated 9 years ago
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- OCaml bindings to libqfs☆13Nov 7, 2025Updated 11 months ago
- telnet protocol in OCaml☆15Nov 15, 2016Updated 9 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- WiP: RFC 4880 (OpenPGP) library and utilities in OCaml☆24Oct 1, 2018Updated 8 years ago
- MirageOS traceroute unikernel☆17Jul 13, 2026Updated 3 months ago
- ☆21Dec 27, 2021Updated 4 years ago
- ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml☆10Apr 3, 2022Updated 4 years ago
- An implementation of some 0MQ RFCs in OCaml for MirageOS☆11May 20, 2019Updated 7 years ago
- OCaml client library for the Tor control port [abandoned]☆10May 1, 2017Updated 9 years ago
- ☆21Dec 29, 2025Updated 10 months ago
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- Example URL shortener MirageOS unikernel using Chamelon.☆18Apr 28, 2022Updated 4 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- A b-tree implementation for Mirage BLOCK devices☆15Oct 15, 2016Updated 10 years ago
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- The Noise Protocol Framework, with types☆26Dec 8, 2021Updated 4 years ago
- Gasoline is an OCaml library providing application templates. Applications written with Gasoline are parametrised by the command line, en…☆16Feb 8, 2018Updated 8 years ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- easy-to-use wrapper for OCaml's Dynlink☆17Jan 9, 2017Updated 9 years ago
- POSIX sendmsg bindings for OCaml☆16Nov 5, 2016Updated 9 years ago
- Precise POSIX clock for OCaml☆15Mar 14, 2019Updated 7 years ago
- ☆23May 25, 2025Updated last year
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Another way to describe mirage☆19Jul 8, 2019Updated 7 years ago
- MirageOS unikernel to test networking☆16Apr 3, 2023Updated 3 years ago
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- (DEPRECATED) Documentation generation for OCaml☆13Jul 16, 2018Updated 8 years ago
- A toolkit for communicating with Emacs from OCaml☆19Jan 24, 2020Updated 6 years ago
- Persistent vectors for OCaml☆41Feb 19, 2018Updated 8 years ago
- Cash is a Unix shell that is embedded within Objective Caml. It's a Caml implementation of (an as large as possible subset of) the API of…☆11Sep 7, 2013Updated 13 years ago