A b-tree implementation for Mirage BLOCK devices
☆15Oct 15, 2016Updated 10 years ago
Alternatives and similar repositories for ocaml-btree
Users that are interested in ocaml-btree are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- ☆11Apr 22, 2016Updated 10 years ago
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- Scalable LRU caches for OCaml☆46Oct 25, 2022Updated 4 years ago
- A B-Tree implementation in OCaml☆24Oct 24, 2016Updated 10 years ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Copy-on-write NFS server☆15Aug 17, 2009Updated 17 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- Io multiplexers bindings for ocaml (poll/kqueue/epoll and so on)☆30Sep 17, 2025Updated last year
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- Bindings to UNIX tuntap facilities☆23Jul 6, 2026Updated 3 months ago
- Scrypt key derivation function in pure OCaml as defined in https://tools.ietf.org/html/draft-josefsson-scrypt-kdf-04☆17Aug 5, 2021Updated 5 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- A toolkit for communicating with Emacs from OCaml☆19Jan 24, 2020Updated 6 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Ocaml NBD library☆14Oct 13, 2026Updated 2 weeks ago
- A Key Value store using a persistent hashtable approach☆19Dec 8, 2021Updated 4 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- Helpers for using topkg with jbuilder☆15Oct 12, 2017Updated 9 years ago
- Implementation of some Erlang primitives in OCaml☆11Jun 16, 2017Updated 9 years ago
- library for network address translation intended for use with mirage unikernels☆33Aug 5, 2026Updated 2 months ago
- Create, parse Apple Plists, plays nicely with Yojson☆10Jan 19, 2017Updated 9 years ago
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- Requirement traceability tool for OCaml☆13Jun 21, 2015Updated 11 years ago
- Continuous Integration for MirageOS using DataKit's git workflow☆20Oct 19, 2020Updated 6 years ago
- A library for manipulation of IP (and MAC) address representations☆40Feb 19, 2026Updated 8 months ago
- Detect root CA certificates from the operating system☆15Jun 22, 2026Updated 4 months ago
- A dashboard displaying useful data from MirageOS project and its related repositories.☆13Sep 7, 2016Updated 10 years ago
- An OCaml library for accessing the Facebook API.☆11Oct 24, 2016Updated 10 years ago
- An implementation of some 0MQ RFCs in OCaml for MirageOS☆11May 20, 2019Updated 7 years ago
- Binding to the WiringPi library☆13Sep 8, 2021Updated 5 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- a MirageOS OAuth2 authorization server for Etsy authentication☆18Jul 15, 2022Updated 4 years ago
- ☆15Aug 16, 2020Updated 6 years ago
- Moana implementation in OCaml☆16Jul 15, 2015Updated 11 years ago
- ☆21Dec 29, 2025Updated 10 months ago
- Thin OCaml bindings to various low-level system APIs not covered by Unix module☆55Sep 29, 2026Updated last month
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- Lambdoc is a library providing support for semantically complex documents in Ocsigen web applications☆16Nov 29, 2023Updated 2 years ago