ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml
☆10Apr 3, 2022Updated 4 years ago
Alternatives and similar repositories for ocaml-chacha
Users that are interested in ocaml-chacha are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Scrypt key derivation function in pure OCaml as defined in https://tools.ietf.org/html/draft-josefsson-scrypt-kdf-04☆17Aug 5, 2021Updated 5 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- OCaml library for building clients and servers that communicate using the Redis Serialization Protocol☆13Nov 6, 2021Updated 5 years ago
- OCaml bindings to libqfs☆13Nov 7, 2025Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Abstract domain library for sets☆10Feb 23, 2023Updated 3 years ago
- telnet protocol in OCaml☆15Nov 15, 2016Updated 9 years ago
- OCaml implementation of histogram-approximation algorithm☆15Oct 28, 2022Updated 4 years ago
- A small command-line tool to help with mechanical edition of opam files☆11Aug 3, 2026Updated 3 months ago
- TLS client program☆11Jun 10, 2020Updated 6 years ago
- Implementation of several spatial indexes (R-tree, etc.)☆18Mar 7, 2023Updated 3 years ago
- ☆17Updated this week
- OCaml implementation of sets as hash tables by Jean-Christophe Filliatre☆11Feb 13, 2025Updated last year
- Gasoline is an OCaml library providing application templates. Applications written with Gasoline are parametrised by the command line, en…☆16Feb 8, 2018Updated 8 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Stripped-down version of mccs with OCaml bindings☆24Jan 9, 2025Updated last year
- Simple, secure and composable I/O abstraction for construction of efficient computation workflows.☆10Jun 11, 2016Updated 10 years ago
- (DEPRECATED) Documentation generation for OCaml☆13Jul 16, 2018Updated 8 years ago
- Dynamic records in OCaml☆26Apr 28, 2023Updated 3 years ago
- Event-based simulation of elastic collisions between balls☆14May 27, 2020Updated 6 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- Zurb Foundation templates for a blog/wiki using Cohttp☆11Sep 10, 2021Updated 5 years ago
- CoreFoundation bindings in OCaml☆15Jul 14, 2020Updated 6 years ago
- Xen event channel interface for Mirage☆10Mar 6, 2025Updated last year
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- ocamldoc comment syntax parser☆21Apr 30, 2020Updated 6 years ago
- Like the tax form, this is an easier interface for quick n dirty XMLM scripts☆13Jan 22, 2020Updated 6 years ago
- ☆11Apr 22, 2016Updated 10 years ago
- OCaml client library for the Tor control port [abandoned]☆10May 1, 2017Updated 9 years ago
- BigArray Utilities☆13Feb 19, 2018Updated 8 years ago
- Cash is a Unix shell that is embedded within Objective Caml. It's a Caml implementation of (an as large as possible subset of) the API of…☆11Sep 7, 2013Updated 13 years ago
- A simple command line tool for statistical calculation☆10May 12, 2018Updated 8 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Convert a cmi file back to an mli interface☆13Oct 4, 2012Updated 14 years ago
- Unicode text for OCaml☆14Feb 19, 2018Updated 8 years ago
- Dig into an opam switch for doc☆10Apr 8, 2022Updated 4 years ago
- Implementation of SeqBox in OCaml☆10Mar 24, 2018Updated 8 years ago
- Moana implementation in OCaml☆16Jul 15, 2015Updated 11 years ago
- A tool for keeping a personal log☆16Jan 1, 2025Updated last year
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago