Library to provide session types to allow for static verification of protocols between concurrent computations.
☆17Jan 1, 2017Updated 9 years ago
Alternatives and similar repositories for sessions
Users that are interested in sessions are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- ☆11Apr 22, 2016Updated 10 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- POSIX sendmsg bindings for OCaml☆16Nov 5, 2016Updated 10 years ago
- telnet protocol in OCaml☆15Nov 15, 2016Updated 9 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- OCaml bindings to libqfs☆13Nov 7, 2025Updated 11 months ago
- ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml☆10Apr 3, 2022Updated 4 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- ocamldoc comment syntax parser☆21Apr 30, 2020Updated 6 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- A git overlay for maildir, providing a strongly consistent index and allowing easy implementation of extra functionality.☆10May 16, 2019Updated 7 years ago
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- s-expression codecs and updates for OCaml☆12Mar 23, 2017Updated 9 years ago
- A toolkit for communicating with Emacs from OCaml☆19Jan 24, 2020Updated 6 years ago
- OCaml CBOR generic decoder/encoder, RFC 7049, http://cbor.io/☆25Feb 7, 2022Updated 4 years ago
- OCaml client library for the Tor control port [abandoned]☆10May 1, 2017Updated 9 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- An implementation of binary session types in OCaml☆39Jun 3, 2019Updated 7 years ago
- OCaml library for building clients and servers that communicate using the Redis Serialization Protocol☆13Nov 6, 2021Updated 5 years ago
- Erlang style process/actor model library in OCaml☆16Apr 23, 2023Updated 3 years ago
- A small script to create short-lived OPAM compiler switches from experimental OCaml branches☆18Jan 4, 2019Updated 7 years ago
- Requirement traceability tool for OCaml☆13Jun 21, 2015Updated 11 years ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- ☆15Aug 16, 2020Updated 6 years ago
- ☆21Dec 29, 2025Updated 10 months ago
- An implementation of some 0MQ RFCs in OCaml for MirageOS☆11May 20, 2019Updated 7 years ago
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- OCaml bindings for jech/dht☆25Jun 16, 2020Updated 6 years ago
- ☆16Jan 16, 2025Updated last year
- A distributed Continuous Integration engine for opam packages☆18Jan 30, 2022Updated 4 years ago
- What do you mean ?☆30Aug 28, 2018Updated 8 years ago
- Emitter for catapult trace viewer, i.e. chrome://tracing☆16Oct 8, 2018Updated 8 years ago
- Relational programming for OCaml (unreleased)☆24Jun 6, 2022Updated 4 years ago
- Scrypt key derivation function in pure OCaml as defined in https://tools.ietf.org/html/draft-josefsson-scrypt-kdf-04☆17Aug 5, 2021Updated 5 years ago