Pure OCaml IKEv2
☆14Nov 15, 2016Updated 9 years ago
Alternatives and similar repositories for ike
Users that are interested in ike are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- OCaml client library for the Tor control port [abandoned]☆10May 1, 2017Updated 9 years ago
- Curve25519 in OCaml.☆16Sep 4, 2018Updated 8 years ago
- Define Grafana dashboards with ReasonML☆18Jan 31, 2020Updated 6 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- Membership protocol for Mirage unikernel clusters based on SWIM☆18Mar 14, 2016Updated 10 years ago
- A dashboard displaying useful data from MirageOS project and its related repositories.☆13Sep 7, 2016Updated 10 years ago
- ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml☆10Apr 3, 2022Updated 4 years ago
- Off-the-record (OTR) messaging protocol, purely in OCaml☆39Dec 17, 2024Updated last year
- ☆21Dec 29, 2025Updated 10 months ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- What do you mean ?☆30Aug 28, 2018Updated 8 years ago
- WIP Handbook for MirageOS☆14Mar 15, 2018Updated 8 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Scrypt key derivation function in pure OCaml as defined in https://tools.ietf.org/html/draft-josefsson-scrypt-kdf-04☆17Aug 5, 2021Updated 5 years ago
- ☆11Apr 22, 2016Updated 10 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- telnet protocol in OCaml☆15Nov 15, 2016Updated 9 years ago
- Should be the next conduit ... or not☆18Apr 20, 2020Updated 6 years ago
- Simple, secure and composable I/O abstraction for construction of efficient computation workflows.☆10Jun 11, 2016Updated 10 years ago
- Entropy driver for MirageOS -- this has been imported into https://github.com/mirage/mirage-crypto☆11Feb 24, 2020Updated 6 years ago
- Emit Logs via syslog☆11Feb 10, 2025Updated last year
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- establish trust in community repositories, cryptographically signed by library authors☆37Nov 12, 2025Updated 11 months ago
- HTML validation on command line☆18Oct 4, 2019Updated 7 years ago
- A toolkit for communicating with Emacs from OCaml☆19Jan 24, 2020Updated 6 years ago
- OCaml library for building clients and servers that communicate using the Redis Serialization Protocol☆13Nov 6, 2021Updated 4 years ago
- TLS client program☆11Jun 10, 2020Updated 6 years ago
- A jabber logger and web interface☆12Updated this week
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- imaplet revamp with Lwt☆18Aug 9, 2017Updated 9 years ago
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- experiments with Brr/Note☆13Aug 27, 2021Updated 5 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- Create, parse Apple Plists, plays nicely with Yojson☆10Jan 19, 2017Updated 9 years ago
- An implementation of some 0MQ RFCs in OCaml for MirageOS☆11May 20, 2019Updated 7 years ago
- Define and generate file and directory carcasses (unreleased)☆17Jun 18, 2020Updated 6 years ago
- A HTTP client relying solely on the OCaml standard library, for use when bootstrapping opam☆13Jul 8, 2019Updated 7 years ago
- Lockless Multiple Producer Single Consumer Queue for ocaml-multicore☆17Mar 20, 2022Updated 4 years ago