Io multiplexers bindings for ocaml (poll/kqueue/epoll and so on)
☆30Sep 17, 2025Updated last year
Alternatives and similar repositories for ocaml-iomux
Users that are interested in ocaml-iomux are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- a small, simple block-backed key-value store for MirageOS☆32Oct 27, 2025Updated last year
- ☆23May 25, 2025Updated last year
- ah yes, effect handlers in unikernels☆14May 19, 2023Updated 3 years ago
- mirror of https://git.robur.coop/robur/http-mirage-client☆11Sep 14, 2026Updated last month
- MirageOS unikernel to test networking☆16Apr 3, 2023Updated 3 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- ☆17Jun 16, 2025Updated last year
- Script that greps anything in the sources of every opam packages☆27Jul 28, 2026Updated 3 months ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- A simple cache system for mmap in OCaml☆14Jan 21, 2026Updated 9 months ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- The caml walks, OCaml runs☆22Oct 11, 2023Updated 3 years ago
- Basic password manager library and command-line application in OCaml☆12Mar 14, 2018Updated 8 years ago
- Detect root CA certificates from the operating system☆15Jun 22, 2026Updated 4 months ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- Moved to https://codeberg.org/kit-ty-kate/mirage-torrent☆17Aug 13, 2026Updated 2 months ago
- Lock-free Sets and Maps for OCaml multicore☆37Sep 20, 2022Updated 4 years ago
- SSH chat server using trust on first use for user registration☆33Oct 9, 2026Updated 3 weeks ago
- A b-tree implementation for Mirage BLOCK devices☆15Oct 15, 2016Updated 10 years ago
- A unikernel as an IRC client☆26Sep 13, 2023Updated 3 years ago
- Xen core platform libraries for MirageOS☆18Aug 14, 2026Updated 2 months ago
- Clone of "An implementation of the Transmission Control Protocol in OCaml"☆38Updated this week
- An implementation of happy eyeballs (RFC 8305) in OCaml with lwt☆24Oct 21, 2026Updated 2 weeks ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Not a filesystem for Mirage block devices☆25Sep 3, 2024Updated 2 years ago
- Experimental opam plugin☆22Jul 21, 2026Updated 3 months ago
- Auditively feel the work of the runtime☆34Mar 1, 2024Updated 2 years ago
- Lockless Multiple Producer Single Consumer Queue for ocaml-multicore☆17Mar 20, 2022Updated 4 years ago
- Hexadecimal encoding and decoding, mirror of https://git.robur.coop/robur/ohex☆10Mar 18, 2024Updated 2 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- line based patch, input is a unified diff☆24Jul 6, 2026Updated 4 months ago
- Eio for JavaScript environments☆13Jan 26, 2026Updated 9 months ago
- Memtrace library for MirageOS☆17Feb 17, 2025Updated last year
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Client library for Maelstrom and solutions to the Fly.io distributed systems challenges - gossip glomers☆14Feb 26, 2023Updated 3 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- a MirageOS OAuth2 authorization server for Etsy authentication☆18Jul 15, 2022Updated 4 years ago
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- Attachment Converter: tool for batch converting attachments in an email mailbox☆12Sep 25, 2026Updated last month
- Interleaved client/server code extraction☆12Jan 30, 2022Updated 4 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago