Binding to libsodium 1.0.9+, a shared library wrapper for djb's NaCl
☆54Nov 26, 2020Updated 5 years ago
Alternatives and similar repositories for ocaml-sodium
Users that are interested in ocaml-sodium are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- Scrypt key derivation function in pure OCaml as defined in https://tools.ietf.org/html/draft-josefsson-scrypt-kdf-04☆17Aug 5, 2021Updated 5 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- A basic SMTP server in OCaml.☆12Oct 24, 2016Updated 10 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Lwt-compatible IMAP4rev1 client library for OCaml☆41Dec 29, 2020Updated 5 years ago
- An OCaml library for accessing the Facebook API.☆11Oct 24, 2016Updated 10 years ago
- ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml☆10Apr 3, 2022Updated 4 years ago
- Off-the-record (OTR) messaging protocol, purely in OCaml☆39Dec 17, 2024Updated last year
- Development OPAM repository for work-in-progress packages☆16Jun 24, 2024Updated 2 years ago
- A planet (feed aggregator) for OCaml.☆27Sep 2, 2026Updated last month
- Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays, based on primitives added in version 4.01.☆14Jun 27, 2022Updated 4 years ago
- (DEPRECATED) Documentation generation for OCaml☆13Jul 16, 2018Updated 8 years ago
- imaplet revamp with Lwt☆18Aug 9, 2017Updated 9 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- OCaml cryptographic library☆111Apr 17, 2020Updated 6 years ago
- Sealing local directories into Mirage Unikernels☆27May 21, 2016Updated 10 years ago
- A collection of functional, mergeable datatypes for Irmin☆12Dec 25, 2016Updated 9 years ago
- An OCaml controller for the Adafruit Rapsberry Pi LCD☆12Jan 6, 2014Updated 12 years ago
- Implementation of SeqBox in OCaml☆10Mar 24, 2018Updated 8 years ago
- ☆40Sep 13, 2026Updated last month
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- Implementation of the PACK file (Git) in OCaml☆20Jun 25, 2020Updated 6 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Pure OCaml implementation of the D-Bus protocol☆35Feb 27, 2024Updated 2 years ago
- Purely functional SSH library in ocaml.☆108Oct 6, 2026Updated 3 weeks ago
- GTK and HTML viewers for mirage-profile trace files☆21Feb 8, 2023Updated 3 years ago
- ☆21Dec 29, 2025Updated 10 months ago
- ☆11Oct 23, 2019Updated 7 years ago
- A library for manipulation of IP (and MAC) address representations☆40Feb 19, 2026Updated 8 months ago
- Zurb Foundation templates for a blog/wiki using Cohttp☆11Sep 10, 2021Updated 5 years ago
- Gasoline is an OCaml library providing application templates. Applications written with Gasoline are parametrised by the command line, en…☆16Feb 8, 2018Updated 8 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- Implementation of several spatial indexes (R-tree, etc.)☆18Mar 7, 2023Updated 3 years ago
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- OCaml bindings to the number theory library PARI/GP☆12Jan 11, 2025Updated last year
- Duration☆17Apr 16, 2026Updated 6 months ago
- OAuth client library in OCaml.☆18Oct 16, 2017Updated 9 years ago
- BigArray Utilities☆13Feb 19, 2018Updated 8 years ago
- Lwt with async backend☆18Jan 2, 2014Updated 12 years ago