OCaml cryptographic library
☆111Apr 17, 2020Updated 6 years ago
Alternatives and similar repositories for ocaml-nocrypto
Users that are interested in ocaml-nocrypto are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Dereference URIs into communication channels for Async or Lwt☆86Nov 24, 2025Updated 11 months ago
- Binding to libsodium 1.0.9+, a shared library wrapper for djb's NaCl☆54Nov 26, 2020Updated 5 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- An OCaml implementation of the FUSE protocol versions 7.8 and 7.23☆30Jan 25, 2018Updated 8 years ago
- A collection of functional, mergeable datatypes for Irmin☆12Dec 25, 2016Updated 9 years ago
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- Sealing local directories into Mirage Unikernels☆27May 21, 2016Updated 10 years ago
- Entropy driver for MirageOS -- this has been imported into https://github.com/mirage/mirage-crypto☆11Feb 24, 2020Updated 6 years ago
- TLS tunnel -- an alternative to stud / stunnel☆87Feb 15, 2023Updated 3 years ago
- X509 (RFC5280) handling in OCaml☆52Sep 24, 2026Updated last month
- TLS in pure OCaml☆321Oct 21, 2026Updated 2 weeks ago
- Thin OCaml bindings to various low-level system APIs not covered by Unix module☆55Sep 29, 2026Updated last month
- Simple templating based on XML ropes☆12Sep 4, 2015Updated 11 years ago
- Embed typed ASN.1 grammars in OCaml☆36Sep 14, 2026Updated last month
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A small script to create short-lived OPAM compiler switches from experimental OCaml branches☆18Jan 4, 2019Updated 7 years ago
- A library for manipulation of IP (and MAC) address representations☆40Feb 19, 2026Updated 8 months ago
- Map OCaml arrays onto C-like structs☆115Sep 5, 2026Updated last month
- A basic SMTP server in OCaml.☆12Oct 24, 2016Updated 10 years ago
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- RSS and Atom feed parsing☆38Mar 6, 2026Updated 7 months ago
- Monotonic wall-clock time for OCaml☆33Aug 13, 2026Updated 2 months ago
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- imaplet revamp with Lwt☆18Aug 9, 2017Updated 9 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Zurb Foundation templates for a blog/wiki using Cohttp☆11Sep 10, 2021Updated 5 years ago
- What do you mean ?☆30Aug 28, 2018Updated 8 years ago
- Scalable LRU caches for OCaml☆46Oct 25, 2022Updated 4 years ago
- Postes, Télégraphes et Téléphones☆27Apr 13, 2026Updated 6 months ago
- The transitory OCaml software packager☆69Sep 8, 2026Updated last month
- Emit Logs via syslog☆11Feb 10, 2025Updated last year
- A collection of tools to manage the configuration of OCaml projects☆53Aug 19, 2015Updated 11 years ago
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- Lwt-compatible IMAP4rev1 client library for OCaml☆41Dec 29, 2020Updated 5 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A session manager for your everyday needs☆43Sep 3, 2022Updated 4 years ago
- Off-the-record (OTR) messaging protocol, purely in OCaml☆39Dec 17, 2024Updated last year
- A DSL to invoke otherworldly functors☆64Aug 25, 2022Updated 4 years ago
- Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays, based on primitives added in version 4.01.☆14Jun 27, 2022Updated 4 years ago
- Scrypt key derivation function in pure OCaml as defined in https://tools.ietf.org/html/draft-josefsson-scrypt-kdf-04☆17Aug 5, 2021Updated 5 years ago
- Small command-line tools for making certificates with OCaml x509/nocrypto toolstack.☆39Feb 17, 2024Updated 2 years ago
- Pure OCaml implementation of the D-Bus protocol☆35Feb 27, 2024Updated 2 years ago