Implementation of do255e and do255s in Go
☆23Dec 14, 2020Updated 5 years ago
Alternatives and similar repositories for go-do255
Users that are interested in go-do255 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- NIST Lightweight Cryptography finalists☆12May 7, 2022Updated 4 years ago
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- NIST P elliptic curves (re-exported from crypto/internal/nistec)☆52Oct 31, 2025Updated 11 months ago
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- Go implementation of libhydrogen - a lightweight, easy-to-use crypto library☆24Mar 23, 2017Updated 9 years ago
- discohash☆15Oct 30, 2021Updated 4 years ago
- Package networkd enables control of systemd-networkd using D-Bus. MIT Licensed.☆16Aug 12, 2023Updated 3 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- BAT KEM/Signature Reference Implementation☆25Dec 28, 2021Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- go implementation of anchorhash☆15Nov 19, 2020Updated 5 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Tool for plotting Go benchmark results☆18Jul 10, 2024Updated 2 years ago
- Pure Go implementation of the Ristretto prime-order group over Edwards25519☆90Jul 15, 2026Updated 3 months ago
- An EXPERIMENTAL Go implementation of the CPace PAKE, instantiated with the ristretto255 group.☆29Feb 11, 2021Updated 5 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Hybrid Public Key Encryption☆51Jul 10, 2024Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Cryptographic Addition Chain Generation in Go☆199Jun 30, 2024Updated 2 years ago
- ☆21Dec 16, 2022Updated 3 years ago
- Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.☆80Oct 13, 2026Updated 2 weeks ago
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago
- filippo.io/edwards25519 — A safer, faster, and more powerful low-level edwards25519 Go implementation.☆189Feb 17, 2026Updated 8 months ago
- Implementation of draft-irtf-cfrg-hpke☆30May 11, 2023Updated 3 years ago
- Interactive object file browser with symbol, source, assembly, and analysis☆22Apr 10, 2024Updated 2 years ago
- xoshiro256** random number generator☆22May 7, 2018Updated 8 years ago
- Convert various benchmarking formats to benchfmt☆13Jan 31, 2025Updated last year
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- A small and easy to use HPKE implementation in Go.☆20Sep 17, 2026Updated last month
- The OPAQUE Asymmetric PAKE Protocol☆115Jan 30, 2025Updated last year
- An implementation of Mike Hamburg's Ed448 (Goldilocks) curve - derived from libdecaf. This is a mirror of https://bugs.otr.im/otrv4/libgo…☆21Mar 16, 2020Updated 6 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- Mirror of my Go Kyber implementation.☆16May 30, 2018Updated 8 years ago
- ☆19Jul 13, 2020Updated 6 years ago
- Implements ristretto255, a fast prime-order group.☆110Feb 19, 2026Updated 8 months ago