Implementation of cryptographic primitives in Go
☆13Mar 13, 2023Updated 3 years ago
Alternatives and similar repositories for nobs
Users that are interested in nobs are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- Mirror of my Go Kyber implementation.☆16May 30, 2018Updated 8 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- Materials accompanying "Implementing an Elliptic Curve in Go"☆13Jul 29, 2017Updated 9 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- ☆10Dec 24, 2018Updated 7 years ago
- An RFC5297-compliant C implementation of AES-SIV☆21Oct 15, 2020Updated 6 years ago
- Work space for golang.org/x/perf version 2☆20Nov 14, 2020Updated 5 years ago
- Solution to harden TLS security by storing private keys and delegating operations to the Trused Execution Environment☆13Oct 10, 2022Updated 4 years ago
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- Slides and other working group materials☆11Feb 5, 2024Updated 2 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Tree-based KEM for group key management☆50Aug 7, 2018Updated 8 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- An implementation of the IETF QUIC protocol in F*☆21Aug 8, 2019Updated 7 years ago
- Implements ristretto255, a fast prime-order group.☆110Feb 19, 2026Updated 8 months ago
- ☆39Jun 2, 2026Updated 4 months ago
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- [work in progress] Python framework for supporting cryptographic game-hopping proofs☆13Oct 19, 2022Updated 4 years ago
- Tamarin proof for the KEMTLS protocol using the multi-stage AKE model☆14Apr 19, 2023Updated 3 years ago
- BAT KEM/Signature Reference Implementation☆25Dec 28, 2021Updated 4 years ago
- TLS in Rust (eventually)☆21Mar 12, 2013Updated 13 years ago
- Implementation of draft-irtf-cfrg-hpke☆30May 11, 2023Updated 3 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- The secure messaging summit information☆20Oct 27, 2020Updated 6 years ago
- CryptoBib Database for Developers☆46Oct 22, 2026Updated last week
- Supersingular Isogeny-Based Cryptography constructions (python-code library)☆52Aug 5, 2022Updated 4 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- A Go library for MerkleSquare: A Low-Latency Transparency Log System☆23Apr 27, 2021Updated 5 years ago
- Reference implementations of post-quantum cryptographic primitives☆32Feb 16, 2026Updated 8 months ago
- Experimental High Assurance Cryptographic Library☆21Feb 1, 2016Updated 10 years ago
- Rust bindings for HACL & Evercrypt☆30Apr 24, 2025Updated last year
- Hybrid Public Key Encryption☆51Jul 10, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- A BibTeX collection on Isogeny-based Cryptography☆18Jan 20, 2023Updated 3 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- The anonymous credentials zoo☆16Mar 17, 2021Updated 5 years ago
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- Message Layer Security☆60Mar 31, 2021Updated 5 years ago
- Talk With TLS: [D]TLS usage Samples, Test and much more☆25Sep 4, 2022Updated 4 years ago
- Google Tink's critical Ed25519 bug related to Java "final" keyword☆11Apr 5, 2020Updated 6 years ago