Pure Go implementation of the Ristretto prime-order group over Edwards25519
☆90Jul 15, 2026Updated 3 months ago
Alternatives and similar repositories for go-ristretto
Users that are interested in go-ristretto are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Implements ristretto255, a fast prime-order group.☆110Feb 19, 2026Updated 8 months ago
- Go version of the Pedersen commitment scheme☆15Apr 11, 2020Updated 6 years ago
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- dalek-compatible implementation of the merlin transcript protocol☆28Feb 11, 2020Updated 6 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- library providing OPRF and Threshold OPRF based on libsodium☆37Sep 1, 2026Updated 2 months ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- a VRF implementation following this ietf draft: https://tools.ietf.org/html/draft-goldbe-vrf-00☆21Jul 16, 2018Updated 8 years ago
- Go Ed25519 suitable for use in consensus-critical contexts.☆53Jan 18, 2024Updated 2 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- The wrapper over asmcgocall to call C functions synchronously, without extra os threads and overhead on it. Probably won't work since 1.1…☆16Feb 20, 2020Updated 6 years ago
- Advanced crypto library for the Go language☆704Jun 22, 2026Updated 4 months ago
- Go implementation of RFC9497, Oblivious Pseudorandom Functions and Verifiable variants.☆16Oct 13, 2026Updated 3 weeks ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago
- ☆45Sep 29, 2021Updated 5 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Golang ed25519☆47May 5, 2021Updated 5 years ago
- High-performance Curve25519/ristretto255 for Go.☆80Jul 10, 2026Updated 3 months ago
- Tool for plotting Go benchmark results☆18Jul 10, 2024Updated 2 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Readable Implementation of Strobe in Go☆26Jan 3, 2022Updated 4 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Updated this week
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Implementations of Ring Signature schemes.☆24Feb 26, 2018Updated 8 years ago
- A Go library for MerkleSquare: A Low-Latency Transparency Log System☆23Apr 27, 2021Updated 5 years ago
- Post-quantum trusted time-stamping server☆17Sep 13, 2026Updated last month
- A pure-go implementation of the Axolotl Ratchet, extracted from pond☆21Feb 8, 2017Updated 9 years ago
- Pure Go implementation of cryptographic APIs found in libsodium☆45Oct 14, 2020Updated 6 years ago
- Compression algorithms in golang☆17Apr 28, 2019Updated 7 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- Cryptographic Addition Chain Generation in Go☆199Jun 30, 2024Updated 2 years ago
- An implementation of the chacha20poly1305 AEAD construction.☆25Nov 27, 2015Updated 10 years ago
- Supersingular Isogeny Diffie-Hellman in Go☆138Oct 25, 2019Updated 7 years ago
- Random collection of zero-knowledge stuff☆15May 20, 2018Updated 8 years ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- Go implementation of libhydrogen - a lightweight, easy-to-use crypto library☆24Mar 23, 2017Updated 9 years ago