An implementation of Mike Hamburg's Ed448 (Goldilocks) curve - derived from libdecaf. This is a mirror of https://bugs.otr.im/otrv4/libgoldilocks
☆21Mar 16, 2020Updated 6 years ago
Alternatives and similar repositories for libgoldilocks
Users that are interested in libgoldilocks are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A golang implementation of Ed448-Goldilocks. This is a mirror of https://bugs.otr.im/otrv4/ed448☆42Feb 25, 2023Updated 3 years ago
- A new implementation of OTR with support for version 4. This is a mirror of https://bugs.otr.im/otrv4/libotr-ng☆41Oct 17, 2022Updated 4 years ago
- SIMD implementation of X25519, Ed25519, X448, Ed448, and Hash to Curve☆34Aug 27, 2026Updated 2 months ago
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- Stronger and Faster Side-Channel Protections for CSIDH☆21Dec 20, 2020Updated 5 years ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Erlang SipHash-2-4 NIF☆13Jul 24, 2024Updated 2 years ago
- Mirror of http://sourceforge.net/p/ed448goldilocks/code/ci/master/tree/☆32Jun 29, 2015Updated 11 years ago
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- Reference implementation of Curve25519 and Curve448 as specified in RFC7748☆10Jun 22, 2019Updated 7 years ago
- Robert Granger and Michael Scott's implementation of scalar multiplication on E521 and P-521☆14May 3, 2015Updated 11 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- sha256(sha256(preimage)) in zk☆15May 12, 2021Updated 5 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Fork of https://bugs.otr.im/plugins/pidgin-otr. This is a mirror of https://bugs.otr.im/otrv4/pidgin-otrng☆17Dec 1, 2019Updated 6 years ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- const fn implementation of the SHA-2 family of hash functions☆20Apr 2, 2026Updated 7 months ago
- Implementation of the Paillier homomorphic cryptosystem using GMP☆28May 18, 2022Updated 4 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- Reference implementations of post-quantum cryptographic primitives☆32Feb 16, 2026Updated 8 months ago
- 白盒CLEFIA加密算法☆14Mar 30, 2016Updated 10 years ago
- ☆33Feb 14, 2025Updated last year
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Light, personalized, interactive dashboards for urban data exploration.☆22Sep 23, 2022Updated 4 years ago
- Materials accompanying "Implementing an Elliptic Curve in Go"☆13Jul 29, 2017Updated 9 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Off-the-Record Messaging Protocol version 4. -This is a draft- This repository is a mirror of http://bugs.otr.im/otrv4/otrv4☆195Oct 17, 2022Updated 4 years ago
- A repository to collect discussion and feedback on the Common Access Token proposal.☆12Jun 25, 2021Updated 5 years ago
- Companion repository for blog post on benchmarking implementations of Paillier encryption☆19Feb 2, 2017Updated 9 years ago
- Implementation of libsodium's secretstream in Go☆23Sep 11, 2026Updated last month
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Solution to harden TLS security by storing private keys and delegating operations to the Trused Execution Environment☆13Oct 10, 2022Updated 4 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Oblivious Pseudorandom Functions (OPRFs) using Prime-Order Groups☆40Sep 10, 2024Updated 2 years ago
- ☆12May 7, 2021Updated 5 years ago
- Circuits for functions of interest to cryptography☆32Updated this week
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- XKCP-extracted code for KangarooTwelve (K12)☆54Nov 26, 2025Updated 11 months ago
- A C++ Implementation of Short Randomizable Signatures (PS Signatures) and EL PASSO (Privacy-preserving, Asynchronous Single Sign-On)☆26Jul 8, 2021Updated 5 years ago
- Pointcheval Sanders signature☆27Mar 16, 2026Updated 7 months ago