The OPAQUE Asymmetric PAKE Protocol
☆116Jan 30, 2025Updated last year
Alternatives and similar repositories for draft-irtf-cfrg-opaque
Users that are interested in draft-irtf-cfrg-opaque are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Oblivious Pseudorandom Functions (OPRFs) using Prime-Order Groups☆40Sep 10, 2024Updated 2 years ago
- An implementation of the OPAQUE password-authenticated key exchange protocol☆426Updated this week
- Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.☆80Oct 13, 2026Updated 3 weeks ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- c implementation of the OPAQUE protocol with bindings for python, php, ruby, lua, zig, java, erlang, golang, js and SASL. also supports a…☆94Jun 24, 2025Updated last year
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Hybrid Public Key Encryption☆51Jul 10, 2024Updated 2 years ago
- ☆65Apr 23, 2026Updated 6 months ago
- ☆45Sep 29, 2021Updated 5 years ago
- library providing OPRF and Threshold OPRF based on libsodium☆37Sep 1, 2026Updated 2 months ago
- Javascript implementation of the Ristretto255 group operations, built on top of the popular TweetNaCl.js crypto library☆35Dec 13, 2023Updated 2 years ago
- An implementation of the OPAQUE protocol☆27Oct 21, 2021Updated 5 years ago
- A TypeScript library for OPAQUE Asymmetric Password-Authenticated Key Exchange Protocol☆112Sep 13, 2026Updated last month
- ☆46Apr 23, 2026Updated 6 months ago
- data-at-rest updatable threshold encryption KMS server and client☆21Sep 24, 2026Updated last month
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- A Go implementation of OPAQUE, a password authenticated key exchange protocol.☆30Dec 4, 2018Updated 7 years ago
- Hashing to Elliptic Curves☆80Sep 8, 2024Updated 2 years ago
- OPAQUE protocol, a secure asymmetric password authenticated key exchange (aPAKE) that supports mutual authentication in a client-server s…☆88Jan 4, 2026Updated 10 months ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- Go implementation of OPAQUE (hidden password user registration and auth)☆56Jul 10, 2020Updated 6 years ago
- ☆23Jan 30, 2025Updated last year
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- elliptic-curve cryptography☆30Oct 8, 2023Updated 3 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Updated this week
- Golang Post Quantum Secure Wire☆19Jul 31, 2025Updated last year
- Demo of the Thinbus Javascript Secure Remote Password SRP SRP6a implementation for web browsers to perform a zero-knowledge proof-of-pass…☆16Aug 21, 2026Updated 2 months ago
- ☆17Aug 26, 2025Updated last year
- An implementation of the OPAQUE key exchange protocol in WASM☆23Apr 11, 2026Updated 6 months ago
- Oblivious pseudorandom function over an elliptic curve☆20Oct 26, 2023Updated 3 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Go implementation of RFC9497, Oblivious Pseudorandom Functions and Verifiable variants.☆16Oct 13, 2026Updated 3 weeks ago
- Sphinx-based Password Storage low-level library☆129Jan 31, 2025Updated last year
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- ☆27Nov 21, 2021Updated 4 years ago
- a reference client/server and a native backend for web-extensions for Sphinx-based password storage☆28Sep 3, 2026Updated 2 months ago
- A small and easy to use HPKE implementation in Go.☆20Sep 17, 2026Updated last month
- An implementation of a verifiable oblivious pseudorandom function (RFC 9497)☆88Updated this week