Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.
☆80Oct 13, 2026Updated 3 weeks ago
Alternatives and similar repositories for opaque
Users that are interested in opaque are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- The OPAQUE Asymmetric PAKE Protocol☆116Jan 30, 2025Updated last year
- Go implementation of RFC9497, Oblivious Pseudorandom Functions and Verifiable variants.☆16Oct 13, 2026Updated 2 weeks ago
- An implementation of the OPAQUE password-authenticated key exchange protocol☆425Jun 23, 2026Updated 4 months ago
- Go implementation of OPAQUE (hidden password user registration and auth)☆56Jul 10, 2020Updated 6 years ago
- ☆44Sep 29, 2021Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Secure password based client-server authentication without the server ever obtaining knowledge of the password. Implementation of the OPA…☆126Oct 23, 2026Updated last week
- A Go implementation of OPAQUE, a password authenticated key exchange protocol.☆30Dec 4, 2018Updated 7 years ago
- library providing OPRF and Threshold OPRF based on libsodium☆37Sep 1, 2026Updated 2 months ago
- Oblivious Pseudorandom Functions (OPRFs) using Prime-Order Groups☆40Sep 10, 2024Updated 2 years ago
- JavaScript implementation of the OPAQUE asymmetric PAKE protocol☆27Nov 23, 2022Updated 3 years ago
- ☆65Apr 23, 2026Updated 6 months ago
- ☆20Sep 5, 2026Updated last month
- A collection of high-performance crypto implementations.☆56Oct 21, 2026Updated last week
- filippo.io/edwards25519 — A safer, faster, and more powerful low-level edwards25519 Go implementation.☆189Feb 17, 2026Updated 8 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Go implementation of RFC9591: the FROST (Flexible Round-Optimized Schnorr Threshold) signing protocol.☆34Jun 18, 2026Updated 4 months ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- CIRCL: Cloudflare Interoperable Reusable Cryptographic Library☆1,733Oct 26, 2026Updated last week
- ☆19Updated this week
- OPAQUE protocol, a secure asymmetric password authenticated key exchange (aPAKE) that supports mutual authentication in a client-server s…☆88Jan 4, 2026Updated 9 months ago
- BAT KEM/Signature Reference Implementation☆25Dec 28, 2021Updated 4 years ago
- A Rust implementation of CPace, a balanced PAKE.☆25Dec 15, 2023Updated 2 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Non-interactive publicly verifiable distributed key generation and resharing algorithm over BLS12-381☆12Jul 26, 2022Updated 4 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A sentry for zero-hit TLS certificate changes in Go☆55Apr 24, 2026Updated 6 months ago
- Platform software for Trusted Computing - TPM 2.0, Certificate Authority, and Web Services required to perform Local and Remote Attestati…☆22Apr 7, 2025Updated last year
- Hybrid Public Key Encryption☆51Jul 10, 2024Updated 2 years ago
- A self-hosted gemini git service☆11Aug 11, 2024Updated 2 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- A repository to collect discussion and feedback on the Common Access Token proposal.☆12Jun 25, 2021Updated 5 years ago
- Auto format DNS zone files☆15Jun 2, 2025Updated last year
- Reference implementations of the GIMLI permutation☆15Jul 9, 2017Updated 9 years ago
- Privacy-first Authorization Framework☆18Jun 12, 2025Updated last year
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Ibex RISC-V core extended with hardware acceleration of cryptography functions☆14May 10, 2024Updated 2 years ago
- An example on how to build & distribute images for Raspberry Pi with mkosi☆14Updated this week
- Automated benchmarking and testing of Post-Quantum Public Key Algoritms (work in progress)☆12Jul 27, 2018Updated 8 years ago
- WIP WireGuard implementation in Go☆14Jul 17, 2016Updated 10 years ago
- Advanced crypto library for the Go language☆12Oct 6, 2026Updated 3 weeks ago
- [mirror] Use U2F for PAM remotely☆10Apr 4, 2020Updated 6 years ago
- Tools to compare Geohash and S2 efficiency☆17Feb 5, 2016Updated 10 years ago