C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.
☆44Nov 10, 2023Updated 2 years ago
Alternatives and similar repositories for rfc7748_precomputed
Users that are interested in rfc7748_precomputed are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A test library for computing modular exponentiation in parallel using AVX-512 vector arithmetic☆12Dec 18, 2023Updated 2 years ago
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- Fast 4 way vectorized ladder for the complete set of Montgomery curves☆11Feb 13, 2019Updated 7 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- An implementation of a post quantum anonymous credential scheme☆17Dec 18, 2024Updated last year
- ☆27Nov 21, 2021Updated 4 years ago
- Stronger and Faster Side-Channel Protections for CSIDH☆21Dec 20, 2020Updated 5 years ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- ☆18Oct 30, 2023Updated 3 years ago
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago
- Experimental High Assurance Cryptographic Library☆21Feb 1, 2016Updated 10 years ago
- ☆37Mar 20, 2017Updated 9 years ago
- like ChaCha, but 64-bit instead of 32-bit thanks to BLAKE2b's permutation☆16Apr 8, 2017Updated 9 years ago
- Hashing to Elliptic Curves☆80Sep 8, 2024Updated 2 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- Constant-time choose between two variables in Clang/LLVM☆21Apr 14, 2018Updated 8 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Please check out https://github.com/hacspec/hacspec for more information on hacspec☆47Nov 11, 2020Updated 5 years ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- Mirror of my Go Kyber implementation.☆16May 30, 2018Updated 8 years ago
- C crypto library☆25Aug 2, 2023Updated 3 years ago
- ABE GPSW scheme using BLS pairing implemented in Rust.☆17May 23, 2023Updated 3 years ago
- SIMD implementation of X25519, Ed25519, X448, Ed448, and Hash to Curve☆34Aug 27, 2026Updated 2 months ago
- Implementation of the SHA-3 family using AVX/AVX2 instructions.☆14Oct 5, 2018Updated 8 years ago
- Slides from talks and other materials related to post-quantum crypto☆12Feb 20, 2021Updated 5 years ago
- BLST-Verification☆23Apr 22, 2026Updated 6 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- Parses https://eprint.iacr.org/eprint-bin/search.pl?last=365&title=1 and sends you an email with the latest papers☆15Nov 11, 2020Updated 5 years ago
- Supersingular Isogeny Diffie-Hellman in Go☆138Oct 25, 2019Updated 7 years ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- ☆12May 7, 2021Updated 5 years ago
- Authenticated Encryption Based on the Masked Even-Mansour (MEM) Construction☆28Apr 20, 2018Updated 8 years ago