NIST Lightweight Cryptography finalists
☆12May 7, 2022Updated 4 years ago
Alternatives and similar repositories for lwcrypto
Users that are interested in lwcrypto are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- High assurance Go secp256k1 (Mirror)☆28Sep 25, 2023Updated 3 years ago
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- A golang implementation of the Haraka v2 family of hash functions☆14Aug 24, 2018Updated 8 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- Tool for plotting Go benchmark results☆18Jul 10, 2024Updated 2 years ago
- String obfuscation in GO☆14Sep 19, 2019Updated 7 years ago
- An EXPERIMENTAL Go implementation of the CPace PAKE, instantiated with the ristretto255 group.☆29Feb 11, 2021Updated 5 years ago
- JavaScript XAES-256-GCM implementation using Web Cryptography API☆14Jul 9, 2026Updated 3 months ago
- RSA Blind Signature Scheme for golang☆29Sep 25, 2017Updated 9 years ago
- slam an HTTP/2 server a lot of concurrent load over a single TCP connection (for debugging something)☆29Mar 24, 2022Updated 4 years ago
- Implementation of Kravatte Encryption Suite☆15Dec 2, 2018Updated 7 years ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- pct is a 'sort | uniq -c' replacement that also prints percentages☆42Apr 19, 2023Updated 3 years ago
- WIP☆21Jun 23, 2025Updated last year
- Leighton-Micali Hash-Based Signatures, for Go☆14Feb 18, 2025Updated last year
- A Go API for perf_event_open☆26Jul 3, 2024Updated 2 years ago
- A command-line tool for prefix-preserving encryption of IP addresses and URIs in logs and data files.☆12Sep 25, 2026Updated last month
- like ChaCha, but 64-bit instead of 32-bit thanks to BLAKE2b's permutation☆16Apr 8, 2017Updated 9 years ago
- xoshiro256** random number generator☆22May 7, 2018Updated 8 years ago
- Experimental committing AEAD designed by Soatok.☆11Sep 10, 2020Updated 6 years ago
- Work space for golang.org/x/perf version 2☆20Nov 14, 2020Updated 5 years ago
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- Exposes batch message receives (recvmmsg)☆14Sep 11, 2026Updated last month
- Small string compression using smaz compression algorithm. Fast, because it's in C. Supports Python 3+☆13Updated this week
- URL-safe compact fixed-width integer encoding☆10May 17, 2023Updated 3 years ago
- Interactive object file browser with symbol, source, assembly, and analysis☆22Apr 10, 2024Updated 2 years ago
- A collection of high-performance crypto implementations.☆56Oct 21, 2026Updated last week
- The history of this repo demonstrates how to take a slow xxd implementation in Go, and make it faster than the native version on OSX/Linu…☆44Nov 16, 2022Updated 3 years ago
- 🔒 Pure Go GOST Security Suite☆12Dec 10, 2022Updated 3 years ago
- Go implementation of Miscreant: misuse-resistant encryption library with AES-SIV (RFC 5297) and AES-PMAC-SIV support☆39Dec 26, 2020Updated 5 years ago
- A simple markdown renderer using react-wasm-bridge☆12Jan 10, 2019Updated 7 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- ☆13Nov 5, 2021Updated 4 years ago
- ☆26Aug 19, 2022Updated 4 years ago
- The AEGIS-128X and AEGIS-256X high performance ciphers.☆39Dec 18, 2024Updated last year
- hashicorp vault gmsm plugin☆14Dec 2, 2025Updated 10 months ago
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- Many queue implementations with a test-suite☆11May 4, 2022Updated 4 years ago
- Go library for Chitin data file format and protocol☆10Jan 22, 2016Updated 10 years ago