[RFC9380] Hash to curves - Go reference implementation
☆21Jul 10, 2026Updated 3 months ago
Alternatives and similar repositories for h2c-go-ref
Users that are interested in h2c-go-ref are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- elliptic curve construction tool☆17Feb 24, 2023Updated 3 years ago
- Hashing to Elliptic Curves☆80Sep 8, 2024Updated 2 years ago
- ☆27Nov 21, 2021Updated 4 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- A test library for computing modular exponentiation in parallel using AVX-512 vector arithmetic☆12Dec 18, 2023Updated 2 years ago
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- Mirror of my Go Kyber implementation.☆16May 30, 2018Updated 8 years ago
- Implementation of the SHA-3 family using AVX/AVX2 instructions.☆14Oct 5, 2018Updated 8 years ago
- An implementation of a post quantum anonymous credential scheme☆17Dec 18, 2024Updated last year
- ☆46Apr 23, 2026Updated 6 months ago
- Nearly generic prime field implementation in Go☆24Feb 11, 2020Updated 6 years ago
- Clang/LLVM patches to zero stack/registers of sensitive functions☆16Apr 14, 2018Updated 8 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- ☆21Dec 16, 2022Updated 3 years ago
- Solution to harden TLS security by storing private keys and delegating operations to the Trused Execution Environment☆13Oct 10, 2022Updated 4 years ago
- Stupid crypto tricks☆18May 12, 2021Updated 5 years ago
- ☆15Jan 22, 2017Updated 9 years ago
- A tool for linear and differential cryptanalysis of block ciphers written in Rust☆15Sep 28, 2022Updated 4 years ago
- ☆11Oct 19, 2026Updated 2 weeks ago
- Authenticated Encryption Based on the Masked Even-Mansour (MEM) Construction☆28Apr 20, 2018Updated 8 years ago
- C crypto library☆25Aug 2, 2023Updated 3 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- is a random text generator based on context-free grammars, it uses a EBNF for grammar definitions.☆20May 5, 2025Updated last year
- Rust bindings for HACL & Evercrypt☆30Apr 24, 2025Updated last year
- like ChaCha, but 64-bit instead of 32-bit thanks to BLAKE2b's permutation☆16Apr 8, 2017Updated 9 years ago
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- A compiler for secure multiparty computation☆50Sep 4, 2016Updated 10 years ago
- Supersingular Isogeny Diffie-Hellman in Go☆138Oct 25, 2019Updated 7 years ago
- Script generated finite field arithmetic for elliptic curve cryptography☆26Oct 23, 2026Updated last week