Work-in-Progress collection of examples of using MirageOS from OCaml
☆22Nov 7, 2017Updated 8 years ago
Alternatives and similar repositories for mirage-examples
Users that are interested in mirage-examples are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Basic password manager library and command-line application in OCaml☆12Mar 14, 2018Updated 8 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- A dashboard displaying useful data from MirageOS project and its related repositories.☆13Sep 7, 2016Updated 10 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- HTML validation on command line☆18Oct 4, 2019Updated 7 years ago
- A HTTP client relying solely on the OCaml standard library, for use when bootstrapping opam☆13Jul 8, 2019Updated 7 years ago
- WIP Handbook for MirageOS☆14Mar 15, 2018Updated 8 years ago
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- A small command-line tool to help with mechanical edition of opam files☆11Aug 3, 2026Updated 2 months ago
- Membership protocol for Mirage unikernel clusters based on SWIM☆18Mar 14, 2016Updated 10 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- (DEPRECATED) Documentation generation for OCaml☆13Jul 16, 2018Updated 8 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- ☆40Sep 13, 2026Updated last month
- Implementation of the PACK file (Git) in OCaml☆20Jun 25, 2020Updated 6 years ago
- WiP: RFC 4880 (OpenPGP) library and utilities in OCaml☆24Oct 1, 2018Updated 8 years ago
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays, based on primitives added in version 4.01.☆14Jun 27, 2022Updated 4 years ago
- ☆11Apr 22, 2016Updated 10 years ago
- a small, simple block-backed key-value store for MirageOS☆32Oct 27, 2025Updated last year
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- ☆18Mar 12, 2016Updated 10 years ago
- Should be the next conduit ... or not☆18Apr 20, 2020Updated 6 years ago
- Entropy driver for MirageOS -- this has been imported into https://github.com/mirage/mirage-crypto☆11Feb 24, 2020Updated 6 years ago
- What do you mean ?☆30Aug 28, 2018Updated 8 years ago
- A simple library for manipulating Master Boot Records☆17Mar 6, 2025Updated last year
- The Noise Protocol Framework, with types☆26Dec 8, 2021Updated 4 years ago
- POSIX sendmsg bindings for OCaml☆16Nov 5, 2016Updated 9 years ago
- A loyal and faithful synchronisation tool that you can rely on.☆47Jun 16, 2016Updated 10 years ago
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- MirageOS IRC daemon.☆14Feb 16, 2018Updated 8 years ago
- Lookup and load installed OCaml modules☆17Aug 13, 2026Updated 2 months ago
- Experimental portable bitmap framebuffer graphics for MirageOS☆17Jul 14, 2020Updated 6 years ago
- Development OPAM repository for work-in-progress packages☆16Jun 24, 2024Updated 2 years ago
- Binding to the WiringPi library☆13Sep 8, 2021Updated 5 years ago
- heterogenous Map over a GADT☆42Dec 17, 2024Updated last year
- Synonym of angkor☆25Mar 4, 2025Updated last year