A DHCP library in OCaml
☆64Sep 15, 2026Updated last month
Alternatives and similar repositories for charrua
Users that are interested in charrua are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- Simple templating based on XML ropes☆12Sep 4, 2015Updated 11 years ago
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- Requirement traceability tool for OCaml☆13Jun 21, 2015Updated 11 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- ☆40Sep 13, 2026Updated last month
- Entropy driver for MirageOS -- this has been imported into https://github.com/mirage/mirage-crypto☆11Feb 24, 2020Updated 6 years ago
- A dashboard displaying useful data from MirageOS project and its related repositories.☆13Sep 7, 2016Updated 10 years ago
- ☆21Dec 29, 2025Updated 10 months ago
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- ☆11Apr 22, 2016Updated 10 years ago
- Work-in-Progress collection of examples of using MirageOS from OCaml☆22Nov 7, 2017Updated 9 years ago
- A small command-line tool to help with mechanical edition of opam files☆11Aug 3, 2026Updated 3 months ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- An OCaml controller for the Adafruit Rapsberry Pi LCD☆12Jan 6, 2014Updated 12 years ago
- Membership protocol for Mirage unikernel clusters based on SWIM☆18Mar 14, 2016Updated 10 years ago
- Unix Filesystem passthrough for MirageOS☆16Oct 30, 2019Updated 7 years ago
- A library for manipulation of IP (and MAC) address representations☆40Feb 19, 2026Updated 8 months ago
- imaplet revamp with Lwt☆18Aug 9, 2017Updated 9 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Implementation of the PACK file (Git) in OCaml☆20Jun 25, 2020Updated 6 years ago
- HTML validation on command line☆18Oct 4, 2019Updated 7 years ago
- Off-the-record (OTR) messaging protocol, purely in OCaml☆39Dec 17, 2024Updated last year
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- ☆18Mar 12, 2016Updated 10 years ago
- ☆18Aug 1, 2015Updated 11 years ago
- An OCaml implementation of the FUSE protocol versions 7.8 and 7.23☆30Jan 25, 2018Updated 8 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- ☆23May 25, 2025Updated last year
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- A collection of functional, mergeable datatypes for Irmin☆12Dec 25, 2016Updated 9 years ago
- Sealing local directories into Mirage Unikernels☆27May 21, 2016Updated 10 years ago
- OCaml embedded eBPF assembler☆24Feb 14, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A b-tree implementation for Mirage BLOCK devices☆15Oct 15, 2016Updated 10 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- A simple library for manipulating Master Boot Records☆17Mar 6, 2025Updated last year
- CoreFoundation bindings in OCaml☆15Jul 14, 2020Updated 6 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- Lookup and load installed OCaml modules☆17Aug 13, 2026Updated 2 months ago
- Bindings to UNIX tuntap facilities☆23Jul 6, 2026Updated 4 months ago