Cash is a Unix shell that is embedded within Objective Caml. It's a Caml implementation of (an as large as possible subset of) the API of Scsh, the Scheme Shell by Olin Shivers. See the Scsh site.
☆11Sep 7, 2013Updated 13 years ago
Alternatives and similar repositories for cash
Users that are interested in cash are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- Some fun with creating little collaborative browser things...☆11Apr 25, 2021Updated 5 years ago
- OCaml implementation of sets as hash tables by Jean-Christophe Filliatre☆11Feb 13, 2025Updated last year
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- OCaml bindings to the number theory library PARI/GP☆12Jan 11, 2025Updated last year
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Data visualization and plotting for OCaml☆19Nov 28, 2017Updated 8 years ago
- ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml☆10Apr 3, 2022Updated 4 years ago
- Gasoline is an OCaml library providing application templates. Applications written with Gasoline are parametrised by the command line, en…☆16Feb 8, 2018Updated 8 years ago
- Fast vectorized bitarrays for OCaml☆16Jul 11, 2023Updated 3 years ago
- Distribute/marshal instances of ocaml extensible variant types and exceptions☆16Nov 26, 2016Updated 9 years ago
- Index your filesystem to find duplicates☆13Mar 28, 2019Updated 7 years ago
- (DEPRECATED) Documentation generation for OCaml☆13Jul 16, 2018Updated 8 years ago
- Stripped-down version of mccs with OCaml bindings☆24Jan 9, 2025Updated last year
- Look at https://github.com/anuragsoni/shuttle_http instead☆15Jan 16, 2026Updated 9 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- DEPRECATED: Compile Time Reflection or Metaprogramming for OCaml☆16Apr 21, 2024Updated 2 years ago
- Basic templates for new OCaml projects☆14Oct 19, 2017Updated 9 years ago
- OCaml bindings to libqfs☆13Nov 7, 2025Updated 11 months ago
- A simple tool and library to embed files and directories inside an OCaml executables☆20Apr 11, 2022Updated 4 years ago
- trial at reviving the ancient library☆11Aug 13, 2026Updated 2 months ago
- OCaml library for resizable arrays and strings☆26Jun 23, 2026Updated 4 months ago
- Strongly typed file paths☆26Jun 11, 2026Updated 4 months ago
- a distributed computing library for OCaml☆25Jan 19, 2024Updated 2 years ago
- Unicode character database decoder for OCaml☆17Sep 17, 2026Updated last month
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Bindings to FFTW3.☆15Feb 6, 2022Updated 4 years ago
- bindings to gnuplot (fork of https://bitbucket.org/ogu/gnuplot-ocaml/)☆13May 6, 2024Updated 2 years ago
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- OCaml library for building clients and servers that communicate using the Redis Serialization Protocol☆13Nov 6, 2021Updated 4 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- A high-performance server for Irmin☆24Oct 1, 2022Updated 4 years ago
- Defunctionalised higher-kinded polymorphism in OCaml.☆20Oct 13, 2020Updated 6 years ago
- OCaml asynchronous scheduler and monad for server-oriented programming.☆16Oct 28, 2026Updated last week
- Implementation of some Erlang primitives in OCaml☆11Jun 16, 2017Updated 9 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- An example project to demonstrate https://github.com/rvantonder/hack-parallel☆13May 18, 2020Updated 6 years ago
- Lightweight PPX extension for OCaml to support natural monadic syntax.☆20Jun 16, 2021Updated 5 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- Constrained Application Protocol (RFC 7252) implementation for OCaml.☆12Apr 3, 2024Updated 2 years ago
- A Key Value store using a persistent hashtable approach☆19Dec 8, 2021Updated 4 years ago
- Finite lazy enumerators in OCaml☆21Oct 19, 2018Updated 8 years ago
- Moana implementation in OCaml☆16Jul 15, 2015Updated 11 years ago