An implementation of the OPAQUE password-authenticated key exchange protocol
☆425Jun 23, 2026Updated 4 months ago
Alternatives and similar repositories for opaque-ke
Users that are interested in opaque-ke are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- An implementation of the OPAQUE key exchange protocol in WASM☆23Apr 11, 2026Updated 6 months ago
- The OPAQUE Asymmetric PAKE Protocol☆116Jan 30, 2025Updated last year
- An implementation of a verifiable oblivious pseudorandom function (RFC 9497)☆88Apr 6, 2026Updated 6 months ago
- Secure password based client-server authentication without the server ever obtaining knowledge of the password. Implementation of the OPA…☆125Oct 23, 2026Updated last week
- c implementation of the OPAQUE protocol with bindings for python, php, ruby, lua, zig, java, erlang, golang, js and SASL. also supports a…☆94Jun 24, 2025Updated last year
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A TypeScript library for OPAQUE Asymmetric Password-Authenticated Key Exchange Protocol☆112Sep 13, 2026Updated last month
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.☆80Oct 13, 2026Updated 2 weeks ago
- OPAQUE protocol, a secure asymmetric password authenticated key exchange (aPAKE) that supports mutual authentication in a client-server s…☆88Jan 4, 2026Updated 9 months ago
- An implementation of an auditable key directory☆336Aug 13, 2026Updated 2 months ago
- Javascript implementation of the Ristretto255 group operations, built on top of the popular TweetNaCl.js crypto library☆35Dec 13, 2023Updated 2 years ago
- A Go implementation of OPAQUE, a password authenticated key exchange protocol.☆30Dec 4, 2018Updated 7 years ago
- Oblivious Pseudorandom Functions (OPRFs) using Prime-Order Groups☆40Sep 10, 2024Updated 2 years ago
- An implementation of the OPAQUE protocol☆27Oct 21, 2021Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- Sphinx-based Password Storage low-level library☆129Jan 31, 2025Updated last year
- ☆46Apr 23, 2026Updated 6 months ago
- library providing OPRF and Threshold OPRF based on libsodium☆37Sep 1, 2026Updated last month
- Go implementation of OPAQUE (hidden password user registration and auth)☆56Jul 10, 2020Updated 6 years ago
- ☆44Sep 29, 2021Updated 5 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- A tool for linear and differential cryptanalysis of block ciphers written in Rust☆15Sep 28, 2022Updated 4 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Simple, predictable pricing with DigitalOcean hosting • AdAlways know what you'll pay with monthly caps and flat pricing. Enterprise-grade infrastructure trusted by 600k+ customers.
- Performance crypto in pure Rust☆58Nov 18, 2025Updated 11 months ago
- A pure-Rust implementation of group operations on Ristretto and Curve25519☆1,207Sep 24, 2026Updated last month
- Password-Authenticated Key Agreement protocols☆124Updated this week
- HashWires is a range proof system for credentials issued by a trusted third party.☆20Jan 28, 2022Updated 4 years ago
- Implementation and simulations for the "Reducing Metadata Leakage from Encrypted Data and Communication with PURBs" paper☆30Oct 26, 2023Updated 3 years ago
- Make AES-GCM safe to use with random nonces, for any practical number of messages.☆19Sep 16, 2025Updated last year
- ABE GPSW scheme using BLS pairing implemented in Rust.☆17May 23, 2023Updated 3 years ago
- Community Cryptography Specification Project☆685Oct 22, 2026Updated last week
- Pure-Rust traits and utilities for constant-time cryptographic implementations.☆312Aug 3, 2024Updated 2 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- ☆65Apr 23, 2026Updated 6 months ago
- A Rust library for lattice-based additive homomorphic encryption.☆419Sep 29, 2023Updated 3 years ago
- Pointcheval Sanders signature☆27Mar 16, 2026Updated 7 months ago
- JavaScript implementation of the OPAQUE asymmetric PAKE protocol☆27Nov 23, 2022Updated 3 years ago
- ☆12May 7, 2021Updated 5 years ago
- A set of Go functions for Secure Remote Password protocol implementation in 1Password Teams☆390Sep 2, 2026Updated last month
- An implementation of Messaging Layer Security (RFC 9420)☆261Updated this week