Secure password based client-server authentication without the server ever obtaining knowledge of the password. Implementation of the OPAQUE protocol.
☆126Oct 23, 2026Updated last week
Alternatives and similar repositories for opaque
Users that are interested in opaque are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A TypeScript library for OPAQUE Asymmetric Password-Authenticated Key Exchange Protocol☆112Sep 13, 2026Updated last month
- TypeScript library offering a Libsodium-compatible API built on top of Noble packages☆24Feb 3, 2026Updated 9 months ago
- Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.☆80Oct 13, 2026Updated 3 weeks ago
- End-to-end encrypted pages for your team☆76May 31, 2024Updated 2 years ago
- An implementation of the OPAQUE protocol☆27Oct 21, 2021Updated 5 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- library providing OPRF and Threshold OPRF based on libsodium☆37Sep 1, 2026Updated 2 months ago
- An implementation of a verifiable oblivious pseudorandom function (RFC 9497)☆88Apr 6, 2026Updated 6 months ago
- Prefixed Entry Object Notation☆12Sep 1, 2025Updated last year
- An implementation of the OPAQUE key exchange protocol in WASM☆23Apr 11, 2026Updated 6 months ago
- Rust library implementing the Toorani-Beheshti signcryption scheme☆13Aug 15, 2023Updated 3 years ago
- The OPAQUE Asymmetric PAKE Protocol☆116Jan 30, 2025Updated last year
- 🌱 Simple event driven server☆19Mar 30, 2026Updated 7 months ago
- The fastest pure TypeScript ML-KEM (NIST FIPS 203) implementation☆63Jul 18, 2026Updated 3 months ago
- Audited & minimal JS implementation of Salsa20, ChaCha and AES☆432Sep 17, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Architecture for end-to-end encrypted CRDTs☆236Sep 21, 2024Updated 2 years ago
- Go implementation of libhydrogen - a lightweight, easy-to-use crypto library☆24Mar 23, 2017Updated 9 years ago
- ☆10Dec 12, 2025Updated 10 months ago
- axolotl based on libsodium☆22Jul 25, 2016Updated 10 years ago
- ☆10Apr 29, 2024Updated 2 years ago
- Auditable & minimal JS implementation of public-key post-quantum cryptography☆368Aug 31, 2026Updated 2 months ago
- Audited & minimal JS implementation of elliptic curve cryptography.☆969Sep 8, 2026Updated last month
- Quickly generate borderless text tables with alignment☆14Jul 26, 2026Updated 3 months ago
- Zero-copy Tor protocol for the web 🏎️ (JS + WebAssembly)☆38Jan 20, 2026Updated 9 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- JSON canonicalize function☆66Sep 18, 2026Updated last month
- Secure Remote Password Protocol implementation in elixir☆20May 14, 2019Updated 7 years ago
- Get the textual position to a property in a JSON text☆12Feb 2, 2023Updated 3 years ago
- Syncronize a YJS document to/from a plain old javascript object☆22Jun 24, 2022Updated 4 years ago
- Auditable WASM implementation of cryptographic hashes & ciphers☆52Sep 12, 2026Updated last month
- ☆15Sep 20, 2025Updated last year
- ☆27Jul 10, 2026Updated 3 months ago
- Audited & minimal JS implementation of hash functions, MACs and KDFs.☆942Sep 8, 2026Updated last month
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- A Go implementation of OPAQUE, a password authenticated key exchange protocol.☆30Dec 4, 2018Updated 7 years ago
- A Messaging Layer Security (RFC 9420, MLS) implementation in TypeScript☆111Updated this week
- ☆65Apr 23, 2026Updated 6 months ago
- Secure, audited & minimal implementation of BIP39 mnemonic phrases☆199Aug 31, 2026Updated 2 months ago
- User-Controlled Authorization Network (UCAN) tokens in go☆43Sep 12, 2026Updated last month
- Capture the flag archives and writeups☆22Oct 27, 2026Updated last week
- ☆12May 15, 2017Updated 9 years ago