A Go implementation of OPAQUE, a password authenticated key exchange protocol.
☆30Dec 4, 2018Updated 7 years ago
Alternatives and similar repositories for opaque
Users that are interested in opaque are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Go implementation of OPAQUE (hidden password user registration and auth)☆56Jul 10, 2020Updated 6 years ago
- An implementation of the OPAQUE protocol☆27Oct 21, 2021Updated 5 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- A set of Go functions for Secure Remote Password protocol implementation in 1Password Teams☆390Sep 2, 2026Updated last month
- Rust library implementing the Toorani-Beheshti signcryption scheme☆13Aug 15, 2023Updated 3 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Oblivious pseudorandom function over an elliptic curve☆20Oct 26, 2023Updated 3 years ago
- The OPAQUE Asymmetric PAKE Protocol☆116Jan 30, 2025Updated last year
- A TypeScript library for OPAQUE Asymmetric Password-Authenticated Key Exchange Protocol☆112Sep 13, 2026Updated last month
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- OPAQUE protocol, a secure asymmetric password authenticated key exchange (aPAKE) that supports mutual authentication in a client-server s…☆88Jan 4, 2026Updated 9 months ago
- ☆46Apr 23, 2026Updated 6 months ago
- Parses https://eprint.iacr.org/eprint-bin/search.pl?last=365&title=1 and sends you an email with the latest papers☆15Nov 11, 2020Updated 5 years ago
- Cipher-based Message Authentication Code as described in RFC4493 and NIST 800-38B☆11May 19, 2022Updated 4 years ago
- Pong revolution.☆16Oct 26, 2025Updated last year
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Proof of Device☆20Jan 20, 2023Updated 3 years ago
- Implementation of libsodium's secretstream in Go☆22Sep 11, 2026Updated last month
- Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.☆80Oct 13, 2026Updated 2 weeks ago
- Secure Remote Password library for Go☆50Oct 5, 2022Updated 4 years ago
- ☆44Sep 29, 2021Updated 5 years ago
- AGL/Golang Standard Library Ed25519 including extra25519 code.☆16Jan 4, 2021Updated 5 years ago
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- Secure and easy crypto for everyone with iOS devices.☆12Jun 29, 2017Updated 9 years ago
- Based on wurstmeister's kafka-docker, with Prometheus JMX Exporter included☆12Nov 24, 2016Updated 9 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Github Actions for Go, it tests and builds your code seamlessly without any hassle.☆23Sep 17, 2022Updated 4 years ago
- a tree. with versions.☆13Jul 26, 2017Updated 9 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- HiAE - A High-Throughput Authenticated Encryption Algorithm for Cross-Platform Efficiency.☆19May 27, 2026Updated 5 months ago
- JavaScript implementation of the OPAQUE asymmetric PAKE protocol☆27Nov 23, 2022Updated 3 years ago
- ☆27Jul 10, 2026Updated 3 months ago
- OCaml implementation of Fiat-Shamir Zero Knowledge Proof system as a client/server authentication protocol☆11Feb 7, 2017Updated 9 years ago
- Xoodyak, a lightweight and versatile cryptographic scheme implemented in Rust.☆30Sep 29, 2026Updated last month
- Fast, modular, and extensible peer to peer library in Go☆13Apr 16, 2019Updated 7 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Building self-contained (offline-only) Haskell program tarballs; only Stack+GHC needed☆10Jun 8, 2017Updated 9 years ago
- Improved Search for Integral, Impossible Differential and Zero-Correlation Attacks: Application to Ascon, ForkSKINNY, SKINNY, MANTIS, PRE…☆14Jul 30, 2025Updated last year
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- Cross platform OIDC agent☆11Feb 24, 2023Updated 3 years ago
- Using clang and llvm to compile C into Web Assembly☆31Nov 10, 2019Updated 6 years ago
- Streaming TopK estimates☆14Sep 25, 2025Updated last year
- Emofishes is a collection of proof-of-concepts that help improve, bypass or detect virtualized execution environments (focusing on the on…☆15Jan 28, 2023Updated 3 years ago