☆46Apr 23, 2026Updated 6 months ago
Alternatives and similar repositories for opaque-core
Users that are interested in opaque-core are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- ☆65Apr 23, 2026Updated 6 months ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- A TypeScript library for OPAQUE Asymmetric Password-Authenticated Key Exchange Protocol☆112Sep 13, 2026Updated last month
- ☆25Apr 23, 2026Updated 6 months ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Go implementation of OPAQUE (RFC 9807), the asymmetric password-authenticated key exchange protocol.☆80Oct 13, 2026Updated 2 weeks ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- The OPAQUE Asymmetric PAKE Protocol☆115Jan 30, 2025Updated last year
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- A TypeScript library for Oblivious Pseudorandom Functions☆38Oct 13, 2026Updated 2 weeks ago
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- ☆27Nov 21, 2021Updated 4 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- Implementation of the SHA-3 family using AVX/AVX2 instructions.☆14Oct 5, 2018Updated 8 years ago
- Oblivious DoH library in Go☆144Sep 26, 2023Updated 3 years ago
- Proves knowledge of an ECDSA-P256 signature under one of many public keys that are stored in a list.☆227Jun 29, 2026Updated 4 months ago
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- JavaScript wrapper for a WebAssembly build of SIDH.☆21Jul 1, 2022Updated 4 years ago
- A test library for computing modular exponentiation in parallel using AVX-512 vector arithmetic☆12Dec 18, 2023Updated 2 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- OPAQUE protocol, a secure asymmetric password authenticated key exchange (aPAKE) that supports mutual authentication in a client-server s…☆88Jan 4, 2026Updated 9 months ago
- A Go implementation of OPAQUE, a password authenticated key exchange protocol.☆30Dec 4, 2018Updated 7 years ago
- Tendermint Core (BFT Consensus) in Go☆13Jul 4, 2021Updated 5 years ago
- Go implementation of OPAQUE (hidden password user registration and auth)☆56Jul 10, 2020Updated 6 years ago
- A repository to collect discussion and feedback on the Common Access Token proposal.☆12Jun 25, 2021Updated 5 years ago
- ☆27Jul 10, 2026Updated 3 months ago
- Central system and configuration manager☆11Apr 24, 2026Updated 6 months ago
- Make AES-GCM safe to use with random nonces, for any practical number of messages.☆19Sep 16, 2025Updated last year
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- An implementation of the OPAQUE password-authenticated key exchange protocol☆424Jun 23, 2026Updated 4 months ago
- ☆22Apr 23, 2026Updated 6 months ago
- Template for durable objects, webpack, commonjs☆21Apr 23, 2026Updated 6 months ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- ☆12Sep 21, 2022Updated 4 years ago
- ☆12Apr 23, 2026Updated 6 months ago
- Webpack loader that transforms JSON Schemas (without $refs) into examples.☆13Apr 24, 2026Updated 6 months ago