library providing OPRF and Threshold OPRF based on libsodium
☆37Sep 1, 2026Updated last month
Alternatives and similar repositories for liboprf
Users that are interested in liboprf are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- c implementation of the OPAQUE protocol with bindings for python, php, ruby, lua, zig, java, erlang, golang, js and SASL. also supports a…☆93Jun 24, 2025Updated last year
- A tool for linear and differential cryptanalysis of block ciphers written in Rust☆15Sep 28, 2022Updated 4 years ago
- data-at-rest updatable threshold encryption KMS server and client☆21Sep 24, 2026Updated last month
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- The OPAQUE Asymmetric PAKE Protocol☆115Jan 30, 2025Updated last year
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- ☆15Sep 2, 2025Updated last year
- Go implementation of RFC9497, Oblivious Pseudorandom Functions and Verifiable variants.☆16Oct 13, 2026Updated 2 weeks ago
- Pure Go implementation of the Ristretto prime-order group over Edwards25519☆90Jul 15, 2026Updated 3 months ago
- ☆25Updated this week
- ☆12Jan 19, 2024Updated 2 years ago
- Make AES-GCM safe to use with random nonces, for any practical number of messages.☆19Sep 16, 2025Updated last year
- Materials accompanying "Implementing an Elliptic Curve in Go"☆13Jul 29, 2017Updated 9 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Banquet implementation☆15May 6, 2022Updated 4 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Identity Based Encryption schemes on the BLS12-381 pairing-friendly elliptic curve☆20Aug 31, 2021Updated 5 years ago
- like ChaCha, but 64-bit instead of 32-bit thanks to BLAKE2b's permutation☆16Apr 8, 2017Updated 9 years ago
- Pointcheval Sanders signature☆27Mar 16, 2026Updated 7 months ago
- GOSTBOX -- A 95-byte program for the 256-byte Streebog/Kuznyechik S-Box.☆17Feb 20, 2021Updated 5 years ago
- Post-quantum trusted time-stamping server☆17Sep 13, 2026Updated last month
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- ☆44Sep 29, 2021Updated 5 years ago
- Compact emulation of the AESENC and AESENCLAST instructions☆11Sep 4, 2017Updated 9 years ago
- BAT KEM/Signature Reference Implementation☆25Dec 28, 2021Updated 4 years ago
- Proof of Device☆20Jan 20, 2023Updated 3 years ago
- A CPace PAKE implementation using libsodium.☆41Dec 31, 2020Updated 5 years ago
- A forward-secure append-only persistent authenticated data structure☆17Jul 5, 2016Updated 10 years ago
- Xoodyak, a lightweight and versatile cryptographic scheme implemented in Rust.☆30Sep 29, 2026Updated last month
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- ☆39Jun 17, 2026Updated 4 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Circuits for functions of interest to cryptography☆32Updated this week
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- An implementation of the axolotl ratchet based on libsodium.☆23Oct 4, 2022Updated 4 years ago
- EyeDP is an Identity Provider☆10Feb 29, 2024Updated 2 years ago
- An implementation of the OPAQUE password-authenticated key exchange protocol☆424Jun 23, 2026Updated 4 months ago
- ☆65Apr 23, 2026Updated 6 months ago
- A small and easy to use HPKE implementation in Go.☆20Sep 17, 2026Updated last month