A sandboxed execution environment for unikernels
☆1,011Oct 28, 2026Updated this week
Alternatives and similar repositories for solo5
Users that are interested in solo5 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Albatross: orchestrate and manage MirageOS unikernels with Solo5☆170Sep 21, 2026Updated last month
- MirageOS is a library operating system that constructs unikernels☆3,021Jul 28, 2026Updated 3 months ago
- The Rumprun unikernel and toolchain for various platforms☆1,178May 11, 2020Updated 6 years ago
- ☆40Sep 13, 2026Updated last month
- Freestanding OCaml runtime☆113Updated this week
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Solo5 core platform libraries for MirageOS☆20Oct 2, 2025Updated last year
- OCI-interfacing Container runtime for Nabla Containers☆256Sep 14, 2021Updated 5 years ago
- Purely functional SSH library in ocaml.☆108Updated this week
- The Unikernel & MicroVM Compilation and Deployment Platform☆2,826Apr 27, 2023Updated 3 years ago
- OSv, a new operating system for the cloud.☆4,265Oct 26, 2026Updated last week
- A git-blogging unikernel written using MirageOS☆123Nov 17, 2023Updated 2 years ago
- A minimal, resource efficient unikernel for cloud services☆5,257May 15, 2026Updated 5 months ago
- A DSL to invoke otherworldly functors☆64Aug 25, 2022Updated 4 years ago
- Xen core platform libraries for MirageOS☆18Aug 14, 2026Updated 2 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Examples of simple MirageOS apps☆236May 8, 2026Updated 5 months ago
- MirageOS unikernels☆53Aug 31, 2026Updated 2 months ago
- A dashboard displaying useful data from MirageOS project and its related repositories.☆13Sep 7, 2016Updated 10 years ago
- Irmin is a distributed database that follows the same design principles as Git☆1,964Oct 9, 2026Updated 3 weeks ago
- Provides a platform to experiment with using Docker to build, distribute and run unikernels.☆95Feb 12, 2018Updated 8 years ago
- The Solo5 unikernel☆14Apr 10, 2019Updated 7 years ago
- EbbRT: elastic building block runtime☆76Jul 23, 2024Updated 2 years ago
- An opinionated implementation of the OpenVPN protocol☆80Sep 14, 2026Updated last month
- WIP Handbook for MirageOS☆14Mar 15, 2018Updated 8 years ago
- End-to-end encrypted email - Proton Mail • AdSpecial offer: 40% Off Yearly / 80% Off First Month. All Proton services are open source and independently audited for security.
- Mirage support for writing QubesOS AppVM unikernels☆66Aug 14, 2026Updated 2 months ago
- A Mirage filesystem library☆47Sep 16, 2021Updated 5 years ago
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- [deprecated, developmeht moved to https://github.com/mirage/ocaml-dns] µDNS - an opinionated Domain Name System (DNS) library☆55Jun 27, 2019Updated 7 years ago
- Read and write FAT format filesystems from OCaml☆25May 31, 2025Updated last year
- a small, simple block-backed key-value store for MirageOS☆32Oct 27, 2025Updated last year
- Infrastructure to collect metrics from OCaml applications.☆46Jun 16, 2025Updated last year
- Easy OCaml bindings for Javascript libraries☆182Jul 15, 2026Updated 3 months ago
- OCaml 4.02 cross compiler for the rumprun unikernel stack☆51Dec 8, 2015Updated 10 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Pure OCaml Git format and protocol☆368May 14, 2025Updated last year
- TLS in pure OCaml☆321Oct 21, 2026Updated last week
- Calendar server (CalDAV, RFC 4791) implementation in OCaml☆62May 10, 2026Updated 5 months ago
- OCaml cryptographic library☆111Apr 17, 2020Updated 6 years ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- Emit Logs via syslog☆11Feb 10, 2025Updated last year
- OCaml implementation of the DNS protocol☆120Sep 13, 2026Updated last month