Multiparty Session Types in OCaml
☆62Nov 1, 2024Updated 2 years ago
Alternatives and similar repositories for ocaml-mpst
Users that are interested in ocaml-mpst are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Monad-based linear types in OCaml, with a few syntax extensions☆39Oct 21, 2019Updated 7 years ago
- OCaml asynchronous scheduler and monad for server-oriented programming.☆16Oct 28, 2026Updated 2 weeks ago
- ☆13Feb 28, 2022Updated 4 years ago
- A toolkit to manipulate Scribble-style multiparty protocols, based on classical multiparty session type theory.☆31Oct 16, 2026Updated 3 weeks ago
- An implementation of binary session types in OCaml☆39Jun 3, 2019Updated 7 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- OCaml implementation of histogram-approximation algorithm☆15Oct 28, 2022Updated 4 years ago
- Library to provide session types to allow for static verification of protocols between concurrent computations.☆17Jan 1, 2017Updated 9 years ago
- Library for finding the CRC of parts of various kinds of data in-place☆11Jul 5, 2024Updated 2 years ago
- Deductive synthesis and compilation of specialized databases.☆13Jul 18, 2023Updated 3 years ago
- Meta-preprocessor for OCaml☆79Jan 3, 2024Updated 2 years ago
- An OCaml library for describing Protobuf messages☆30Feb 4, 2021Updated 5 years ago
- Software construction and deployment kit☆41Oct 21, 2026Updated 3 weeks ago
- A traceable distributed computation framework☆23Oct 8, 2019Updated 7 years ago
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 9 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Tools for migrating away from Lwt☆15Apr 27, 2026Updated 6 months ago
- ☆12Nov 21, 2019Updated 6 years ago
- Functional Monadic Library for Ocaml☆56Jun 1, 2026Updated 5 months ago
- OCaml CBOR generic decoder/encoder, RFC 7049, http://cbor.io/☆25Feb 7, 2022Updated 4 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- An OCaml wrapper to the AF_XDP socket interface of libbpf☆27Jul 9, 2024Updated 2 years ago
- The core parallel and shared memory library used by Hack, Flow, and Pyre☆41Feb 27, 2021Updated 5 years ago
- Generate Shell Phrases In OCaml☆47Dec 15, 2021Updated 4 years ago
- a MirageOS OAuth2 authorization server for Etsy authentication☆18Jul 15, 2022Updated 4 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- RPC client/server for Irmin☆19Aug 5, 2021Updated 5 years ago
- Moana implementation in OCaml☆16Jul 15, 2015Updated 11 years ago
- Dig into an opam switch for doc☆10Apr 8, 2022Updated 4 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- Small tensor library a la GLSL☆17Oct 28, 2022Updated 4 years ago
- TEA for the shell, in OCaml☆40May 6, 2019Updated 7 years ago
- OCaml bindings to libqfs☆13Nov 7, 2025Updated last year
- OCaml implementation of sets as hash tables by Jean-Christophe Filliatre☆11Feb 13, 2025Updated last year
- Implementation of SMTP protocols in OCaml☆48Oct 7, 2026Updated last month
- End-to-end encrypted email - Proton Mail • AdSpecial offer: 40% Off Yearly / 80% Off First Month. All Proton services are open source and independently audited for security.
- An OCaml client library for Discord☆13Jan 24, 2016Updated 10 years ago
- A ppx rewriter that provides pattern matching on abstract types by transforming patterns into views/expressions.☆19Sep 24, 2019Updated 7 years ago
- A client side load balancing library for ocaml☆18Aug 11, 2018Updated 8 years ago
- trial at reviving the ancient library☆11Aug 13, 2026Updated 3 months ago
- OCaml library for building clients and servers that communicate using the Redis Serialization Protocol☆13Nov 6, 2021Updated 5 years ago
- Experimental opam plugin☆22Jul 21, 2026Updated 3 months ago
- OCaml binary heap implementation by Jean-Christophe Filliatre☆18Nov 29, 2020Updated 5 years ago
Are these results useful?