Monad-based linear types in OCaml, with a few syntax extensions
☆39Oct 21, 2019Updated 6 years ago
Alternatives and similar repositories for linocaml
Users that are interested in linocaml are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Multiparty Session Types in OCaml☆61Nov 1, 2024Updated last year
- OCaml asynchronous scheduler and monad for server-oriented programming.☆16Apr 8, 2025Updated last year
- A simple photo gallery webapp☆15Jun 1, 2021Updated 5 years ago
- OCaml binding to LXC with idiomatic (and opionated) OCaml API design☆13Oct 25, 2019Updated 6 years ago
- Serialization formats toolkit for OCaml (unreleased)☆13Jan 2, 2026Updated 8 months ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 5 years ago
- [DEPRECATED (use avro-simple)] Runtime library and schema compiler for the Avro serialization format.☆21Jul 7, 2026Updated 2 months ago
- Basic password manager library and command-line application in OCaml☆12Mar 14, 2018Updated 8 years ago
- OCaml implementation of sets as hash tables by Jean-Christophe Filliatre☆11Feb 13, 2025Updated last year
- runtime library and code-generator for BARE (https://baremessages.org/)☆23Aug 16, 2024Updated 2 years ago
- Interacting with cron from OCaml☆14Apr 16, 2022Updated 4 years ago
- Distribute/marshal instances of ocaml extensible variant types and exceptions☆16Nov 26, 2016Updated 9 years ago
- A gRPC implementation written in pure OCaml/Reason☆16Apr 12, 2019Updated 7 years ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- Some fun with creating little collaborative browser things...☆11Apr 25, 2021Updated 5 years ago
- Type-level rational puzzles in OCaml☆25Jun 8, 2016Updated 10 years ago
- This is a repo that can be cloned to get started quickly with Sihl.☆14Aug 10, 2021Updated 5 years ago
- Dig into an opam switch for doc☆10Apr 8, 2022Updated 4 years ago
- Simple and type-safe dataframe api implemented in pure ocaml☆23Apr 24, 2021Updated 5 years ago
- HTTP combinators for MirageOS☆11Oct 11, 2019Updated 6 years ago
- easy-to-use wrapper for OCaml's Dynlink☆17Jan 9, 2017Updated 9 years ago
- An OCaml clustering library☆20Apr 26, 2021Updated 5 years ago
- unloading modules with ocaml native☆16Dec 13, 2020Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Letters is an OCaml library for creating and sending emails over SMTP using LWT☆55Jan 14, 2025Updated last year
- OCaml binary heap implementation by Jean-Christophe Filliatre☆18Nov 29, 2020Updated 5 years ago
- A dynamic way to instantiate an OCaml flow☆19Jul 15, 2026Updated 2 months ago
- Ocamldap is an implementation of the Light Weight Directory Access Protocol☆15Dec 8, 2025Updated 9 months ago
- Js_of_ocaml bindings for MithrilJS☆18Jan 23, 2021Updated 5 years ago
- Trivial/Tagless Polytypic Functions☆24Apr 14, 2020Updated 6 years ago
- OCaml interface for creating Dockerfiles☆68Sep 10, 2026Updated 2 weeks ago
- Fast native fibers for OCaml☆39Nov 27, 2018Updated 7 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Pure & Incomplete STUN protocol in OCaml☆15Dec 8, 2022Updated 3 years ago
- An implementation of binary session types in OCaml☆39Jun 3, 2019Updated 7 years ago
- Another way to describe mirage☆19Jul 8, 2019Updated 7 years ago
- a mirage kernel using esy☆18Jan 20, 2021Updated 5 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- Software construction and deployment kit☆41Aug 13, 2026Updated last month
- Simple OCaml interface for Gnuplot☆11Oct 6, 2021Updated 4 years ago