OCaml asynchronous scheduler and monad for server-oriented programming.
☆16Oct 28, 2026Updated last week
Alternatives and similar repositories for ocaml-duppy
Users that are interested in ocaml-duppy are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- [unreleased] A parser and generator library for a simple subset of YAML in pure OCaml☆13Dec 10, 2018Updated 7 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- Basic password manager library and command-line application in OCaml☆12Mar 14, 2018Updated 8 years ago
- Cash is a Unix shell that is embedded within Objective Caml. It's a Caml implementation of (an as large as possible subset of) the API of…☆11Sep 7, 2013Updated 13 years ago
- End-to-end encrypted email - Proton Mail • AdSpecial offer: 40% Off Yearly / 80% Off First Month. All Proton services are open source and independently audited for security.
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Erlang style process/actor model library in OCaml☆16Apr 23, 2023Updated 3 years ago
- Arbitrary-precision decimal based on Zarith☆21Updated this week
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- Datatype-generic object-oriented transformations for OCaml☆17Aug 29, 2026Updated 2 months ago
- Synonym of angkor☆25Mar 4, 2025Updated last year
- Alternative interpreter for OCaml format strings☆15Apr 4, 2023Updated 3 years ago
- ☆21Dec 29, 2025Updated 10 months ago
- Transactions, Keys, and Values☆21Nov 3, 2017Updated 9 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Fast msgpack library for OCaml☆28Jun 8, 2021Updated 5 years ago
- Defunctionalised higher-kinded polymorphism in OCaml.☆20Oct 13, 2020Updated 6 years ago
- Functional kernel written in OCaml.☆37Nov 14, 2013Updated 12 years ago
- ImpFS, a new filesystem.☆22Feb 6, 2022Updated 4 years ago
- MirageOS traceroute unikernel☆17Jul 13, 2026Updated 3 months ago
- An implementation of happy eyeballs (RFC 8305) in OCaml with lwt☆24Oct 21, 2026Updated 2 weeks ago
- Algorithms and datastructures for phylogenetics☆14Dec 24, 2025Updated 10 months ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- Monad-based linear types in OCaml, with a few syntax extensions☆39Oct 21, 2019Updated 7 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- What do you mean ?☆30Aug 28, 2018Updated 8 years ago
- Interleaved client/server code extraction☆12Jan 30, 2022Updated 4 years ago
- easy-to-use wrapper for OCaml's Dynlink☆17Jan 9, 2017Updated 9 years ago
- Reflect the essence of OCaml types as values☆15Sep 3, 2026Updated 2 months ago
- HTTP combinators for MirageOS☆11Oct 11, 2019Updated 7 years ago
- An OCaml client library for Discord☆13Jan 24, 2016Updated 10 years ago
- Adaptive Radix Tree in OCaml☆52May 8, 2026Updated 5 months ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- A B-Tree implementation in OCaml☆24Oct 24, 2016Updated 10 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Parallelize _anything_ //☆54Oct 5, 2023Updated 3 years ago
- Trivial/Tagless Polytypic Functions☆24Apr 14, 2020Updated 6 years ago
- Library to drive Lego mindstorm NXT bricks from OCaml. Communication with the NXT brick is done through bluetooth.☆17Jul 25, 2023Updated 3 years ago
- Letters is an OCaml library for creating and sending emails over SMTP using LWT☆55Jan 14, 2025Updated last year
- Distribute/marshal instances of ocaml extensible variant types and exceptions☆16Nov 26, 2016Updated 9 years ago
- Fast, safe mutable dynamic arrays for OCaml☆29Jan 18, 2024Updated 2 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago