Functional kernel written in OCaml.
☆37Nov 14, 2013Updated 12 years ago
Alternatives and similar repositories for funk
Users that are interested in funk are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- An implementation of happy eyeballs (RFC 8305) in OCaml with lwt☆24Oct 21, 2026Updated last week
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- s-expression codecs and updates for OCaml☆12Mar 23, 2017Updated 9 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- OCaml asynchronous scheduler and monad for server-oriented programming.☆16Apr 8, 2025Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- A set of tools to work with Gameboy stuff☆14Dec 4, 2022Updated 3 years ago
- Hexadecimal encoding and decoding, mirror of https://git.robur.coop/robur/ohex☆10Mar 18, 2024Updated 2 years ago
- Interleaved client/server code extraction☆12Jan 30, 2022Updated 4 years ago
- [unreleased] A parser and generator library for a simple subset of YAML in pure OCaml☆13Dec 10, 2018Updated 7 years ago
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- MirageOS unikernel to test networking☆16Apr 3, 2023Updated 3 years ago
- Library to read metadata from files in various formats.☆14Sep 3, 2026Updated last month
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- WIP IndieWeb blog engine☆15Jan 21, 2020Updated 6 years ago
- telnet protocol in OCaml☆15Nov 15, 2016Updated 9 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- MirageOS traceroute unikernel☆17Jul 13, 2026Updated 3 months ago
- Simple OCaml interface for Gnuplot☆11Oct 6, 2021Updated 5 years ago
- Alternative interpreter for OCaml format strings☆15Apr 4, 2023Updated 3 years ago
- Paste-eur as unikernel☆76Jun 30, 2026Updated 4 months ago
- Implementation of the PACK file (Git) in OCaml☆20Jun 25, 2020Updated 6 years ago
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- Fast char sets☆21May 2, 2026Updated 5 months ago
- experiments on distributed unikernels☆16Dec 15, 2024Updated last year
- Nullable-array is a small self-contained library providing an efficient implementation for a type equivalent to `'a option array`☆18May 5, 2021Updated 5 years ago
- line based patch, input is a unified diff☆24Jul 6, 2026Updated 3 months ago
- a shared pixel display controllable via TCP☆13Jan 25, 2024Updated 2 years ago
- Should be the next conduit ... or not☆18Apr 20, 2020Updated 6 years ago
- Library to drive Lego mindstorm NXT bricks from OCaml. Communication with the NXT brick is done through bluetooth.☆17Jul 25, 2023Updated 3 years ago
- A simple unikernel which provides a search engine from an emails archive☆14Apr 11, 2026Updated 6 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Detect root CA certificates from the operating system☆15Jun 22, 2026Updated 4 months ago
- Library for finding the CRC of parts of various kinds of data in-place☆11Jul 5, 2024Updated 2 years ago
- CommonMark parser and renderer for OCaml☆50Sep 14, 2026Updated last month
- ELF-parsing library written in OCaml for OCaml☆14May 30, 2012Updated 14 years ago
- Another way to describe mirage☆19Jul 8, 2019Updated 7 years ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- Cash is a Unix shell that is embedded within Objective Caml. It's a Caml implementation of (an as large as possible subset of) the API of…☆11Sep 7, 2013Updated 13 years ago