Experimental High Assurance Cryptographic Library
☆21Feb 1, 2016Updated 10 years ago
Alternatives and similar repositories for hacl
Users that are interested in hacl are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Authenticated Encryption Based on the Masked Even-Mansour (MEM) Construction☆28Apr 20, 2018Updated 8 years ago
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- An implementation of Poly1305 for mips32r2 processors, based on the donna32 algorithm☆12Mar 1, 2015Updated 11 years ago
- misc stuff☆19Jun 1, 2017Updated 9 years ago
- Please check out https://github.com/hacspec/hacspec for more information on hacspec☆47Nov 11, 2020Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- PoC of Swift for Compute@Edge☆12Feb 3, 2022Updated 4 years ago
- A C++ library for DANE protocols, focusing on secure email☆12Apr 18, 2017Updated 9 years ago
- NORX implementation in Rust☆17Apr 8, 2015Updated 11 years ago
- ☆11Oct 19, 2014Updated 12 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Updated this week
- Jump to Full Encryption☆61Oct 29, 2016Updated 10 years ago
- Materials accompanying "Implementing an Elliptic Curve in Go"☆13Jul 29, 2017Updated 9 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆42Nov 10, 2023Updated 2 years ago
- Links to stuff arising from or related to the HACS workshop.☆34Feb 9, 2018Updated 8 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- The repo of rust crate 'releasetag'. Releasetags can be extracted from application crash-files postmortem☆13May 1, 2019Updated 7 years ago
- ☆12May 7, 2021Updated 5 years ago
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- ☆171Mar 15, 2021Updated 5 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- ssh key exchange layer for scapy☆13Oct 27, 2014Updated 12 years ago
- ☆17Sep 4, 2014Updated 12 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- ☆30Jul 29, 2014Updated 12 years ago
- Lightweight cryptographic hash functions (reference code)☆16May 2, 2014Updated 12 years ago
- libsodium for Universal Windows Platform (UWP) - A secure cryptographic library☆16Jun 24, 2018Updated 8 years ago
- Crypto Bib is a BibTeX database containing papers related to Cryptography, with manually checked entries and uniform BibTeX data.☆12Nov 6, 2015Updated 11 years ago
- Rust Cryptography Intrinsics☆12May 9, 2019Updated 7 years ago
- Dynamic binary instrumentation based crypto detection framework. Implementation of http://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&arnumbe…☆18Feb 22, 2013Updated 13 years ago
- GitHub Integration for managing CLA signatures☆21Sep 22, 2017Updated 9 years ago
- A tweakable block cipher☆31May 17, 2024Updated 2 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Simple proxy designed to intercept and modify connections on the transport level. This means you can also modify TLS raw bytes.☆17Dec 13, 2021Updated 4 years ago
- Interactive object file browser with symbol, source, assembly, and analysis☆22Apr 10, 2024Updated 2 years ago
- Open Bitcoin QR Code Maker☆11Apr 13, 2020Updated 6 years ago
- Automated Cryptographic Transformations☆26Aug 23, 2021Updated 5 years ago
- Lightweight program that pollinates STHs between Certificate Transparency logs and auditors☆27Aug 7, 2025Updated last year
- A robust RFC5322/2822/822 message parser☆18Mar 19, 2022Updated 4 years ago
- GNU Radio module for data encryption using NaCl library☆26Mar 2, 2020Updated 6 years ago
Are these results useful?