Reference implementations of post-quantum cryptographic primitives
☆32Feb 16, 2026Updated 8 months ago
Alternatives and similar repositories for pqc
Users that are interested in pqc are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- Solution to harden TLS security by storing private keys and delegating operations to the Trused Execution Environment☆13Oct 10, 2022Updated 4 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- Circuits for functions of interest to cryptography☆32Updated this week
- End-to-end encrypted email - Proton Mail • AdSpecial offer: 40% Off Yearly / 80% Off First Month. All Proton services are open source and independently audited for security.
- Pointcheval Sanders signature☆27Mar 16, 2026Updated 7 months ago
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- ☆17Aug 2, 2021Updated 5 years ago
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago
- Slides from talks and other materials related to post-quantum crypto☆12Feb 20, 2021Updated 5 years ago
- Fast 4 way vectorized ladder for the complete set of Montgomery curves☆11Feb 13, 2019Updated 7 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Mirror of my Go Kyber implementation.☆16May 30, 2018Updated 8 years ago
- A tool for linear and differential cryptanalysis of block ciphers written in Rust☆15Sep 28, 2022Updated 4 years ago
- ☆12May 7, 2021Updated 5 years ago
- A fork of Open Quantum Safe Project's fork of OpenSSL 1.1.1m, which adds QUIC protocol support from the quictls project.☆10Feb 9, 2022Updated 4 years ago
- Blind RSA signatures for OpenSSL/BoringSSL.☆17Sep 25, 2026Updated last month
- ☆18Mar 11, 2026Updated 7 months ago
- Proof of Device☆20Jan 20, 2023Updated 3 years ago
- I-D that describes the algorithm identifiers for NIST's PQC ML-DSA for use in the Internet X.509 Public Key Infrastructure☆14Oct 30, 2025Updated last year
- Xoodyak, a lightweight and versatile cryptographic scheme implemented in Rust.☆30Sep 29, 2026Updated last month
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Wycheproof for Rust☆23Sep 10, 2026Updated last month
- Sparse MerkleTree implementation in Rust☆19Oct 16, 2019Updated 7 years ago
- Deterministic/nonce-reuse resistant authenticated encryption scheme using XChaCha20, implemented on libsodium.☆31Aug 5, 2024Updated 2 years ago
- ☆27Nov 21, 2021Updated 4 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- A standalone AES-KW (AES Key Wrap) implementation.☆14Dec 31, 2023Updated 2 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- ☆24May 14, 2025Updated last year
- A C++ Implementation of Short Randomizable Signatures (PS Signatures) and EL PASSO (Privacy-preserving, Asynchronous Single Sign-On)☆26Jul 8, 2021Updated 5 years ago
- An implementation of Mike Hamburg's Ed448 (Goldilocks) curve - derived from libdecaf. This is a mirror of https://bugs.otr.im/otrv4/libgo…☆21Mar 16, 2020Updated 6 years ago
- We implement Delegatable Anonymous Credentials using Mercurial Signatures☆21Jun 7, 2022Updated 4 years ago
- Tamarin proof for the KEMTLS protocol using the multi-stage AKE model☆14Apr 19, 2023Updated 3 years ago
- Efficient Anonymous Tokens with Private Metadata Bit☆16Mar 7, 2023Updated 3 years ago