Supersingular Isogeny Diffie-Hellman in Go
☆138Oct 25, 2019Updated 7 years ago
Alternatives and similar repositories for sidh
Users that are interested in sidh are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- SIDH Library is a fast and portable software library that implements state-of-the-art supersingular isogeny cryptographic schemes. The ch…☆330Sep 15, 2026Updated last month
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- SIDH C reference implementation☆13Jan 25, 2017Updated 9 years ago
- crypto/tls, now with 100% more 1.3. THE API IS NOT STABLE AND DOCUMENTATION IS NOT GUARANTEED.☆299Apr 24, 2026Updated 6 months ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- Nearly generic prime field implementation in Go☆24Feb 11, 2020Updated 6 years ago
- Hashing to Elliptic Curves☆80Sep 8, 2024Updated 2 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- Implements ristretto255, a fast prime-order group.☆110Feb 19, 2026Updated 8 months ago
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- ☆16Mar 27, 2018Updated 8 years ago
- High Assurance Cryptographic Software☆10Sep 1, 2026Updated last month
- Slides from talks and other materials related to post-quantum crypto☆12Feb 20, 2021Updated 5 years ago
- ☆14May 3, 2019Updated 7 years ago
- xoshiro256** random number generator☆22May 7, 2018Updated 8 years ago
- Software for "Quantum-Resistant Cryptosystems from Supersingular Elliptic Curve Isogenies"☆89Jul 11, 2019Updated 7 years ago
- Code to fuzz bignum libraries☆46Nov 11, 2018Updated 7 years ago
- ☆15Jan 22, 2017Updated 9 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- A port of Stream VByte to Go☆35Feb 22, 2022Updated 4 years ago
- A golang implementation of the Haraka v2 family of hash functions☆14Aug 24, 2018Updated 8 years ago
- Reference implementations of the GIMLI permutation☆15Jul 9, 2017Updated 9 years ago
- Classical simulator for Kuperberg's quantum collimation sieve, generalized to arbitrary finite cyclic groups and focused on CSIDH-512.☆15Jun 18, 2019Updated 7 years ago
- Pure Go implementation of the Ristretto prime-order group over Edwards25519☆90Jul 15, 2026Updated 3 months ago
- A design for doing more private Signal groups using anonymous credentials based on algebraic MACs.☆14Dec 20, 2019Updated 6 years ago
- An AVX/AVX2/x64/pure-Go implementation of the ChaCha20 stream cipher for Golang. [Deprecated].☆11Mar 15, 2018Updated 8 years ago
- ipcipher implementation in Go☆17Dec 19, 2023Updated 2 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Golang Post Quantum Secure Wire☆19Jul 31, 2025Updated last year
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Mirror of http://sourceforge.net/p/ed448goldilocks/code/ci/master/tree/☆32Jun 29, 2015Updated 11 years ago
- Cryptographic Addition Chain Generation in Go☆199Jun 30, 2024Updated 2 years ago
- RFC version of TLS 1.3 -- for collaboration with RFC publication center☆11Jul 5, 2022Updated 4 years ago
- CIRCL: Cloudflare Interoperable Reusable Cryptographic Library☆1,733Updated this week
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago