A compiler from a small functional language to C. Especially features algebraic effects and handlers with multishot continuations, and a static type system with inference of types and effects, with subtyping.
☆93Dec 10, 2018Updated 7 years ago
Alternatives and similar repositories for joujou
Users that are interested in joujou are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Work on modular implicits☆25Oct 23, 2018Updated 8 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 5 years ago
- Serialization formats toolkit for OCaml (unreleased)☆13Jan 2, 2026Updated 9 months ago
- An OCaml client library for Discord☆13Jan 24, 2016Updated 10 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- Implementation of the PACK file (Git) in OCaml☆20Jun 25, 2020Updated 6 years ago
- Implementation of some Erlang primitives in OCaml☆11Jun 16, 2017Updated 9 years ago
- A toy language based on LLVM that implements the System Fω type-system☆114Aug 14, 2023Updated 3 years ago
- Interleaved client/server code extraction☆12Jan 30, 2022Updated 4 years ago
- A clean implementation of Parsing with Zippers.☆39Sep 22, 2018Updated 8 years ago
- Pack file encoder/decoder in OCaml☆12Jun 2, 2017Updated 9 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Persistent vectors for OCaml☆41Feb 19, 2018Updated 8 years ago
- A simple photo gallery webapp☆15Jun 1, 2021Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Relational programming for OCaml (unreleased)☆24Jun 6, 2022Updated 4 years ago
- System Fω interpreter for use in Advanced Functional Programming course☆74Oct 16, 2023Updated 3 years ago
- Another way to describe mirage☆19Jul 8, 2019Updated 7 years ago
- Efficient binder representation in OCaml☆45Jul 5, 2024Updated 2 years ago
- Code using GADT☆39Apr 5, 2021Updated 5 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- An implementation of some 0MQ RFCs in OCaml for MirageOS☆11May 20, 2019Updated 7 years ago
- A tool to create PDFs that are also OCaml bytecodes☆42Sep 19, 2023Updated 3 years ago
- ☆21Sep 26, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Transducers in OCaml. About as Haskelly as you can manage. Hoping to fix that.☆16Feb 14, 2015Updated 11 years ago
- Library to provide session types to allow for static verification of protocols between concurrent computations.☆17Jan 1, 2017Updated 9 years ago
- Infrastructure to collect metrics from OCaml applications.☆46Jun 16, 2025Updated last year
- A Datalog implementation with an OCaml inspired module system☆45Oct 13, 2026Updated 2 weeks ago
- Curve25519 in OCaml.☆16Sep 4, 2018Updated 8 years ago
- Basic password manager library and command-line application in OCaml☆12Mar 14, 2018Updated 8 years ago
- Algorithms to layout trees in a pretty manner.☆36Mar 7, 2022Updated 4 years ago
- Software construction and deployment kit☆41Oct 21, 2026Updated last week
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- LINQ-like combinators for manipulating collections of in-memory data☆16Sep 21, 2020Updated 6 years ago
- Small tensor library a la GLSL☆17Oct 28, 2022Updated 4 years ago
- An OCaml controller for the Adafruit Rapsberry Pi LCD☆12Jan 6, 2014Updated 12 years ago
- What do you mean ?☆30Aug 28, 2018Updated 8 years ago
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- a MirageOS OAuth2 authorization server for Etsy authentication☆18Jul 15, 2022Updated 4 years ago