Persistent vectors for OCaml
☆41Feb 19, 2018Updated 8 years ago
Alternatives and similar repositories for pvec
Users that are interested in pvec are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Map à la Binary Radix Tree☆19Mar 10, 2022Updated 4 years ago
- Unicode text for OCaml☆14Feb 19, 2018Updated 8 years ago
- A safer C FFI for OCaml☆18Dec 13, 2018Updated 7 years ago
- Lookup and load installed OCaml modules☆17Aug 13, 2026Updated 2 months ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- QOI image codec for OCaml (unreleased)☆11Aug 13, 2026Updated 2 months ago
- automatic ci configuration for the people☆36Nov 20, 2019Updated 6 years ago
- Future values for asynchronous programming in OCaml (unreleased)☆20Jun 18, 2020Updated 6 years ago
- Algorithms to layout trees in a pretty manner.☆36Mar 7, 2022Updated 4 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- Implementation of the PACK file (Git) in OCaml☆20Jun 25, 2020Updated 6 years ago
- Fast, safe and composable streaming abstractions.☆120Nov 25, 2024Updated last year
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Functional Priority Search Queues for OCaml☆53Mar 30, 2024Updated 2 years ago
- Constant time equal function to avoid timing attacks in OCaml☆50Jun 27, 2024Updated 2 years ago
- An implementation of some 0MQ RFCs in OCaml for MirageOS☆11May 20, 2019Updated 7 years ago
- line based patch, input is a unified diff☆24Jul 6, 2026Updated 3 months ago
- Monotonic wall-clock time for OCaml☆33Aug 13, 2026Updated 2 months ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Interleaved client/server code extraction☆12Jan 30, 2022Updated 4 years ago
- Should be the next conduit ... or not☆18Apr 20, 2020Updated 6 years ago
- Example URL shortener MirageOS unikernel using Chamelon.☆18Apr 28, 2022Updated 4 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- The caml walks, OCaml runs☆22Oct 11, 2023Updated 3 years ago
- Fast msgpack library for OCaml☆28Jun 8, 2021Updated 5 years ago
- Letters is an OCaml library for creating and sending emails over SMTP using LWT☆55Jan 14, 2025Updated last year
- Distribute/marshal instances of ocaml extensible variant types and exceptions☆16Nov 26, 2016Updated 9 years ago
- Trivial/Tagless Polytypic Functions☆24Apr 14, 2020Updated 6 years ago
- Serialization formats toolkit for OCaml (unreleased)☆13Jan 2, 2026Updated 9 months ago
- Unicode character database decoder for OCaml☆17Sep 17, 2026Updated last month
- OCaml Tetris☆25May 8, 2019Updated 7 years ago
- ☆23May 25, 2025Updated last year
- Simple, predictable pricing with DigitalOcean hosting • AdAlways know what you'll pay with monthly caps and flat pricing. Enterprise-grade infrastructure trusted by 600k+ customers.
- WiP: RFC 4880 (OpenPGP) library and utilities in OCaml☆24Oct 1, 2018Updated 8 years ago
- Painless micro-benchmarks☆21Mar 6, 2019Updated 7 years ago
- ᚛ A type of divination employed in attempts to locate identifiers matching a given type expression☆38Jun 5, 2026Updated 4 months ago
- An OCaml toplevel (REPL) upgrade☆90Aug 13, 2026Updated 2 months ago
- A tool that creates stand-alone source bundles from opam packages☆28Oct 2, 2026Updated 3 weeks ago
- Fast implementation of queue in OCaml☆52Feb 26, 2024Updated 2 years ago
- CommonMark parser and renderer for OCaml☆50Sep 14, 2026Updated last month