System Fω interpreter for use in Advanced Functional Programming course
☆74Oct 16, 2023Updated 3 years ago
Alternatives and similar repositories for fomega
Users that are interested in fomega are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Fast char sets☆21May 2, 2026Updated 5 months ago
- A compiler from a small functional language to C. Especially features algebraic effects and handlers with multishot continuations, and a …☆93Dec 10, 2018Updated 7 years ago
- Type-classes for mirage applications☆12Oct 3, 2016Updated 10 years ago
- Lambdoc is a library providing support for semantically complex documents in Ocsigen web applications☆16Nov 29, 2023Updated 2 years ago
- A "implementation" of Girard's paradox in OCaml☆113Apr 7, 2015Updated 11 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- A Toy Inverse Bidirectional Typechecker☆33May 13, 2019Updated 7 years ago
- easy-to-use wrapper for OCaml's Dynlink☆17Jan 9, 2017Updated 9 years ago
- Abstract domain library for sets☆10Feb 23, 2023Updated 3 years ago
- RFC 1035 Internet domain names☆10Oct 13, 2025Updated last year
- OCaml with typed algebraic effects☆53Oct 12, 2018Updated 8 years ago
- ☆12Feb 11, 2019Updated 7 years ago
- [research] A modular SMT solver in OCaml, based on mcSAT☆37Jan 1, 2024Updated 2 years ago
- Yet another type combinator library☆56Mar 10, 2022Updated 4 years ago
- OCaml with macros☆67Oct 8, 2026Updated 3 weeks ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Simple OCaml interface for Gnuplot☆11Oct 6, 2021Updated 5 years ago
- Invariant Generation as Type Inference with GADTs and Existentials☆18Sep 8, 2026Updated last month
- OCaml hash-consing library☆57May 28, 2026Updated 5 months ago
- OpenType font decoder for OCaml☆20Aug 13, 2026Updated 2 months ago
- A safer C FFI for OCaml☆18Dec 13, 2018Updated 7 years ago
- Repo of the original work on finally tagless (and a lot of other metaocaml work besides)☆44Nov 28, 2018Updated 7 years ago
- Misc algorithms in OCaml (HyperLogLog, jump consistent hashing)☆72Updated this week
- ☆21Dec 29, 2025Updated 10 months ago
- A formalization of System Fω in Agda☆20Dec 23, 2025Updated 10 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A phylogenetic tree of animals☆13Sep 25, 2016Updated 10 years ago
- BigArray Utilities☆13Feb 19, 2018Updated 8 years ago
- Type inference for ML-like languages. A port to F# of "Algorithm W Step by Step" by Martin Grabmüller.☆11Sep 17, 2014Updated 12 years ago
- Fωμ type checker and compiler☆58Jan 28, 2023Updated 3 years ago
- An OCaml library for accessing the Facebook API.☆11Oct 24, 2016Updated 10 years ago
- Reasonable Go.☆10Aug 13, 2018Updated 8 years ago
- Lets you create interactive shells in OCaml.☆11Sep 13, 2016Updated 10 years ago
- A planet (feed aggregator) for OCaml.☆27Sep 2, 2026Updated last month
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- Work on modular implicits☆25Oct 23, 2018Updated 8 years ago
- Requirement traceability tool for OCaml☆13Jun 21, 2015Updated 11 years ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- Small tensor library a la GLSL☆17Oct 28, 2022Updated 4 years ago
- Lockless Multiple Producer Single Consumer Queue for ocaml-multicore☆17Mar 20, 2022Updated 4 years ago
- Wob extended wtih effect handlers☆14Sep 25, 2023Updated 3 years ago
- An eDSL for MirageOS apps☆20Jul 30, 2018Updated 8 years ago