i18n Translator for Go/Golang using CLDR data + pluralization rules
☆430Sep 20, 2026Updated last month
Alternatives and similar repositories for universal-translator
Users that are interested in universal-translator are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- a set of locales generated from the CLDR Project which can be used independently or within an i18n package; these were built for use wit…☆308Sep 28, 2026Updated last month
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Translate your Go program into multiple languages.☆3,552Updated this week
- Go Struct and Field validation, including Cross Field, Cross Struct, Map, Slice and Array diving☆20,219Updated this week
- Decodes url.Values into Go value(s) and Encodes Go value(s) into url.Values. Dual Array and Full map support.☆933Oct 31, 2026Updated last week
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Civil Date and Time package for Go☆19Feb 23, 2022Updated 4 years ago
- library + program to help making zero downtime, self-upgrading programs and servers.☆16Jul 14, 2016Updated 10 years ago
- Error Context, Stack Trace, Types and Tags for full error handling and logging.☆67Oct 18, 2023Updated 3 years ago
- A golang i18n tool using CLDR data☆25Sep 15, 2021Updated 5 years ago
- Is a general library to help modify or set data within data structures and other objects.☆308Dec 29, 2024Updated last year
- Trims, sanitizes & scrubs data based on struct tags (go, golang)☆323Jul 15, 2025Updated last year
- Embeds static resources into go files for single binary compilation + works with http.FileSystem + symlinks☆67Oct 5, 2016Updated 10 years ago
- :non-potable_water: Is a lightweight HTTP router that sticks to the std "net/http" implementation☆153Jul 13, 2023Updated 3 years ago
- CloudyKit Router fastest router for go☆23Feb 28, 2025Updated last year
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Go library for decoding generic map values into native Go structures and vice versa.☆8,009Jun 25, 2024Updated 2 years ago
- [Go] Package of validators and sanitizers for strings, numerics, slices and structs☆6,202Nov 1, 2026Updated last week
- Useful template functions for Go templates.☆4,753Jul 18, 2025Updated last year
- ☆15Jan 24, 2022Updated 4 years ago
- An idiomatic Go (golang) validation package. Supports configurable and extensible validation rules (validators) using normal language con…☆4,157Oct 27, 2026Updated last week
- Basic Assertion Library used along side native go testing, with building blocks for custom assertions☆67Sep 12, 2022Updated 4 years ago
- Go (Golang) GNU gettext utilities package☆514Oct 14, 2026Updated 3 weeks ago
- Package for comparing Go values in tests☆4,685Oct 29, 2026Updated last week
- Go Humans! (formatters for units to human friendly sizes)☆4,856Oct 13, 2026Updated 3 weeks ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- The Universal Filesystem Abstraction for Go☆6,719Oct 30, 2026Updated last week
- Go package for UUIDs based on RFC 4122 and DCE 1.1: Authentication and Security Services.☆6,156Nov 14, 2024Updated last year
- Now is a time toolkit for golang☆4,715Feb 2, 2026Updated 9 months ago
- URL-friendly slugify with multiple languages support.☆1,335Dec 23, 2024Updated last year
- GoMock is a mocking framework for the Go programming language.☆9,319Jan 8, 2024Updated 2 years ago
- Command line tool to generate idiomatic Go code for SQL databases supporting PostgreSQL, MySQL, SQLite, Oracle, and Microsoft SQL Server☆3,899Sep 8, 2026Updated 2 months ago
- safe and easy casting from one type to another in Go☆3,982Sep 9, 2026Updated last month
- cross-platform Golang helpers for reading password input without cgo☆119Jun 27, 2024Updated 2 years ago
- json reference for golang☆20Oct 9, 2026Updated 3 weeks ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Arbitrary-precision fixed-point decimal numbers in Go☆7,512Nov 1, 2026Updated last week
- ARCHIVE - Golang implementation of JSON Web Tokens (JWT). This project is now maintained at:☆10,722Nov 4, 2021Updated 5 years ago
- ☆11Sep 15, 2017Updated 9 years ago
- Ruby on Rails like test fixtures for Go. Write tests against a real database☆1,241Oct 21, 2026Updated 2 weeks ago
- Faster snakecase implementation☆43Jun 26, 2023Updated 3 years ago
- golang port of Google's libphonenumber☆632Apr 8, 2024Updated 2 years ago
- HTTP middleware for Go that facilitates some quick security wins.☆2,359Oct 10, 2026Updated 3 weeks ago