a set of locales generated from the CLDR Project which can be used independently or within an i18n package; these were built for use with, but not exclusive to https://github.com/go-playground/universal-translator
☆309Sep 28, 2026Updated last month
Alternatives and similar repositories for locales
Users that are interested in locales are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- i18n Translator for Go/Golang using CLDR data + pluralization rules☆429Sep 20, 2026Updated last month
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Civil Date and Time package for Go☆19Feb 23, 2022Updated 4 years ago
- Decodes url.Values into Go value(s) and Encodes Go value(s) into url.Values. Dual Array and Full map support.☆933Updated this week
- Translate your Go program into multiple languages.☆3,552Updated this week
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- ☆15Jan 24, 2022Updated 4 years ago
- Embeds static resources into go files for single binary compilation + works with http.FileSystem + symlinks☆67Oct 5, 2016Updated 10 years ago
- library + program to help making zero downtime, self-upgrading programs and servers.☆16Jul 14, 2016Updated 10 years ago
- A golang i18n tool using CLDR data☆25Sep 15, 2021Updated 5 years ago
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- Go Struct and Field validation, including Cross Field, Cross Struct, Map, Slice and Array diving☆20,215Updated this week
- ☆927Jul 23, 2026Updated 3 months ago
- Timezone Country and Zone data generated from timezonedb.com☆36Aug 13, 2024Updated 2 years ago
- Is a general library to help modify or set data within data structures and other objects.☆309Dec 29, 2024Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Server-Sent Events implementation in Go. Used by the Gin Framework.☆153Oct 23, 2026Updated last week
- Basic Assertion Library used along side native go testing, with building blocks for custom assertions☆67Sep 12, 2022Updated 4 years ago
- jsonpointer for golang with support for structs☆53Oct 9, 2026Updated 3 weeks ago
- Go (Golang) GNU gettext utilities package☆513Oct 14, 2026Updated 2 weeks ago
- idiomatic codec and rpc lib for msgpack, cbor, json, etc. msgpack.org[Go]☆1,966Sep 2, 2026Updated 2 months ago
- Now is a time toolkit for golang☆4,711Feb 2, 2026Updated 8 months ago
- ansi contains a bunch of constants and possibly additional terminal related functionality in the future.☆15Nov 11, 2019Updated 6 years ago
- A high-performance 100% compatible drop-in replacement of "encoding/json"☆13,856May 27, 2024Updated 2 years ago
- Simple string pattern matcher for Go☆140Sep 5, 2025Updated last year
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Go library for the TOML file format☆2,001Aug 3, 2026Updated 2 months ago
- Is a library that aids in graceful shutdown of a process/application☆49Mar 27, 2017Updated 9 years ago
- reflect api without runtime reflect.Value cost☆828Mar 22, 2025Updated last year
- Go package for UUIDs based on RFC 4122 and DCE 1.1: Authentication and Security Services.☆6,152Nov 14, 2024Updated last year
- [Go] Package of validators and sanitizers for strings, numerics, slices and structs☆6,203Updated this week
- FastPrinter supports write values in io.Writer without allocation☆12Dec 2, 2025Updated 11 months ago
- Go Humans! (formatters for units to human friendly sizes)☆4,853Oct 13, 2026Updated 2 weeks ago
- Checks for a new line before return and branch statements.☆28Apr 4, 2024Updated 2 years ago
- A Go implementation of the 64-bit xxHash algorithm (XXH64)☆2,149Jul 3, 2024Updated 2 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- logr implementation against the stdlib log package☆36Jul 14, 2022Updated 4 years ago
- ARCHIVE - Golang implementation of JSON Web Tokens (JWT). This project is now maintained at:☆10,725Nov 4, 2021Updated 4 years ago
- semver library in Go☆366Jul 22, 2026Updated 3 months ago
- Efficient JSON beautifier and compactor for Go☆422Sep 27, 2026Updated last month
- Go library for decoding generic map values into native Go structures and vice versa.☆8,011Jun 25, 2024Updated 2 years ago
- A toolkit with common assertions and mocks that plays nicely with the standard library☆26,241Oct 19, 2026Updated last week
- Optimized Go Compression Packages☆5,708Updated this week