Basic Assertion Library used along side native go testing, with building blocks for custom assertions
☆67Sep 12, 2022Updated 4 years ago
Alternatives and similar repositories for assert
Users that are interested in assert are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A Chrome extension for golang users.When you're at golang's official doc site, it will show function's description as tooltip on function…☆13Dec 3, 2022Updated 3 years ago
- ansi contains a bunch of constants and possibly additional terminal related functionality in the future.☆15Nov 11, 2019Updated 6 years ago
- A memcached binary protocol toolkit for go.☆12Updated this week
- A heat map plugin that works with HTML tables to create chart, it uses colour to visualize a two-dimensional matrix of values.☆14Oct 22, 2015Updated 11 years ago
- library + program to help making zero downtime, self-upgrading programs and servers.☆16Jul 14, 2016Updated 10 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Is a library that aids in graceful shutdown of a process/application☆49Mar 27, 2017Updated 9 years ago
- Embeds static resources into go files for single binary compilation + works with http.FileSystem + symlinks☆67Oct 5, 2016Updated 10 years ago
- A project around helping to prevent typing typos. TySug (Typo Suggestions) suggests alternative words with respect to keyboard layouts☆20Oct 20, 2026Updated last week
- Library for interruptable, resumable download acceleration with automatic Accept-Ranges support☆41May 29, 2017Updated 9 years ago
- simple auto-compile daemon that just works☆19Apr 24, 2021Updated 5 years ago
- Multi-Package go project coverprofile for tools like goveralls☆116Dec 30, 2019Updated 6 years ago
- i18n Translator for Go/Golang using CLDR data + pluralization rules☆429Sep 20, 2026Updated last month
- a set of locales generated from the CLDR Project which can be used independently or within an i18n package; these were built for use wit…☆309Sep 28, 2026Updated last month
- cmd tool for automatic storage and comparison of benchmarks results☆19Sep 1, 2016Updated 10 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- 增强型errors包(for golang)☆10Dec 9, 2018Updated 7 years ago
- Library that make mocking of Go functions/methods easy☆15May 24, 2024Updated 2 years ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- lodash throttle like Go library☆40Aug 24, 2021Updated 5 years ago
- Go Client Library for Amazon's Product Advertising API 5.0☆16Apr 3, 2020Updated 6 years ago
- porter stemmer☆14Feb 9, 2026Updated 8 months ago
- Retry provides a set of standardized common components and abstracts away some code that normally is duplicated☆18Dec 31, 2017Updated 8 years ago
- Package libpd provides an idiomatic Go-lang wrapper for Pure Data embeddable audio synthesis library.☆19Sep 22, 2016Updated 10 years ago
- AKS Deployment Automation with Terraform and Multi-AKS Cluster Management with Rancher, AAD Integration and more☆15Mar 16, 2019Updated 7 years ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- A convenience library for executing commands in Go, including executing commands in parallel with a pool.☆16Nov 22, 2012Updated 13 years ago
- Simple Reporting for Google Analytics☆15Jun 9, 2015Updated 11 years ago
- no nonsense job runner☆14May 31, 2026Updated 5 months ago
- Monitors Go MemStats + System stats such as Memory, Swap and CPU and sends via UDP anywhere you want for logging etc...☆172Sep 7, 2016Updated 10 years ago
- A Go library help testing your RESTful API application☆54Jul 2, 2026Updated 3 months ago
- Command pattern for Go with thread safe serial and parallel dispatcher☆14Apr 20, 2016Updated 10 years ago
- Write and read JSON from different sources in one line☆10Apr 7, 2020Updated 6 years ago
- Golanger is a lightweight framework for writing web applications in Go.☆16Sep 16, 2012Updated 14 years ago
- manipulate and inspect VCS repositories in Go☆82Sep 16, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Declarative golang HTTP client☆24Mar 28, 2026Updated 7 months ago
- Simple and expressive toolbox written in Go☆25Jun 30, 2016Updated 10 years ago
- Detect blank strings or remove whitespace from strings☆14Jul 31, 2019Updated 7 years ago
- Simple, configurable and scalable Structured Logging for Go.☆293Aug 17, 2023Updated 3 years ago
- Go bindings based on the JSON API errors reference☆13Nov 17, 2016Updated 9 years ago
- Run a command periodically, because CRON sucks☆10Jun 20, 2014Updated 12 years ago
- Severity-based key/value logging replacement for Go's standard logger.☆17Apr 3, 2026Updated 6 months ago