Fluent assertion-style functions used by goconvey and gunit. Can also be used in any test or application.
☆99Jan 20, 2026Updated 9 months ago
Alternatives and similar repositories for assertions
Users that are interested in assertions are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- Goroutine local storage☆698Aug 12, 2022Updated 4 years ago
- A memcached binary protocol toolkit for go.☆12Oct 29, 2026Updated last week
- Data model artifacts for Prometheus.☆80Oct 10, 2026Updated 3 weeks ago
- ☆14Sep 30, 2026Updated last month
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Civil Date and Time package for Go☆19Feb 23, 2022Updated 4 years ago
- Go testing in the browser. Integrates with `go test`. Write behavioral tests in Go.☆8,397Jul 30, 2024Updated 2 years ago
- Go implementation of RFC-5802 Salted Challenge Response Authentication Mechanism (SCRAM)☆54Updated this week
- Library to translate OTLP metric and attribute names to Prometheus metric and label names.☆16Oct 23, 2026Updated 2 weeks ago
- ☆12Jun 29, 2022Updated 4 years ago
- logr implementation against the stdlib log package☆36Jul 14, 2022Updated 4 years ago
- Effective Computation of Things☆115Aug 15, 2019Updated 7 years ago
- 📙 The Axone Ontology☆12Updated this week
- Dataframe library for Go.☆17Jul 15, 2023Updated 3 years ago
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- Partial port of Python difflib package to Go☆429May 30, 2023Updated 3 years ago
- Go package providing information about the number of CPUs in the system☆34Updated this week
- ☆23Nov 25, 2022Updated 3 years ago
- ☆17Aug 16, 2026Updated 2 months ago
- PTY interface for Go☆23Jul 2, 2019Updated 7 years ago
- 增强型errors包(for golang)☆10Dec 9, 2018Updated 7 years ago
- ☆13Aug 4, 2015Updated 11 years ago
- the clean architecture, optimised for Golang☆15Oct 19, 2018Updated 8 years ago
- ☆13Sep 10, 2018Updated 8 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Docker Compose (and Daemon) in Docker☆12Jun 6, 2016Updated 10 years ago
- 🚔 Enforce field tags in (un)marshaled structs☆40Jan 19, 2026Updated 9 months ago
- Java properties scanner for Go☆340Sep 16, 2026Updated last month
- ☆118Apr 11, 2026Updated 6 months ago
- Rich testing for the Go language☆694Jul 26, 2024Updated 2 years ago
- Go Utilities - logging and json helpers☆13Oct 19, 2021Updated 5 years ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Go libraries shared across Prometheus components and libraries.☆297Updated this week
- Golang library for the BlinkyTape☆13Jun 24, 2019Updated 7 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Go package for dealing with maps, slices, JSON and other data.☆875Updated this week
- Package pop3 provides an implementation of the Post Office Protocol - Version 3.☆20Jun 26, 2021Updated 5 years ago
- ☆18Apr 2, 2018Updated 8 years ago
- Implements a deep pretty printer for Go data structures to aid in debugging☆6,423Apr 6, 2024Updated 2 years ago
- A common logging package for HashiCorp tools☆350Oct 15, 2026Updated 3 weeks ago
- Golang CQL Cassandra Driver conforming to the built-in database/sql interface☆21Sep 20, 2020Updated 6 years ago
- reflect api without runtime reflect.Value cost☆829Mar 22, 2025Updated last year