Partial port of Python difflib package to Go
☆429May 30, 2023Updated 3 years ago
Alternatives and similar repositories for go-difflib
Users that are interested in go-difflib are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Diff, match and patch text in Go☆2,090Jun 5, 2025Updated last year
- Implements a deep pretty printer for Go data structures to aid in debugging☆6,425Apr 6, 2024Updated 2 years ago
- ☆927Jul 23, 2026Updated 3 months ago
- Pretty printing for Go values☆1,409Jul 26, 2024Updated 2 years ago
- Unified diff parser and printer for Go☆468Oct 20, 2026Updated last week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Simple code templating for Go☆19Jun 26, 2017Updated 9 years ago
- Go Humans! (formatters for units to human friendly sizes)☆4,851Oct 13, 2026Updated 2 weeks ago
- The Snappy compression format in the Go programming language.☆1,573Jul 16, 2026Updated 3 months ago
- wcwidth for golang☆725Oct 8, 2026Updated 3 weeks ago
- The Universal Filesystem Abstraction for Go☆6,714Updated this week
- concurrency utilities☆304Aug 9, 2019Updated 7 years ago
- Project has been moved to: https://github.com/go-git/go-git☆4,873Apr 10, 2022Updated 4 years ago
- Selected Go-internal packages factored out from the standard library☆993Oct 5, 2026Updated 3 weeks ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Go package for dealing with maps, slices, JSON and other data.☆874Oct 23, 2026Updated last week
- Miscellaneous functions for formatting text☆96Jul 26, 2024Updated 2 years ago
- Go library for the TOML file format☆2,001Aug 3, 2026Updated 2 months ago
- Go glob☆1,042Sep 8, 2026Updated last month
- A Go (golang) library for parsing and verifying versions and version constraints.☆1,775Oct 16, 2026Updated 2 weeks ago
- Simple error handling primitives☆8,257Mar 27, 2026Updated 7 months ago
- Package for comparing Go values in tests☆4,681Jun 18, 2026Updated 4 months ago
- ☆12Aug 22, 2022Updated 4 years ago
- Serves embedded files from `jteeuwen/go-bindata` with `net/http`☆863Feb 1, 2025Updated last year
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Data model artifacts for Prometheus.☆80Oct 10, 2026Updated 2 weeks ago
- Blackfriday: a markdown processor for Go☆5,594Jan 29, 2024Updated 2 years ago
- Package stack implements utilities to capture, manipulate, and format call stacks.☆404Aug 18, 2021Updated 5 years ago
- Mergo: merging Go structs and maps since 2013☆3,108Oct 12, 2026Updated 2 weeks ago
- Cross-platform filesystem notifications for Go.☆10,805May 11, 2026Updated 5 months ago
- ☆15Jan 24, 2022Updated 4 years ago
- psutil for golang☆11,940Updated this week
- A Go implementation of the 64-bit xxHash algorithm (XXH64)☆2,148Jul 3, 2024Updated 2 years ago
- [Deprecated] Protocol Buffers for Go with Gadgets☆5,654Jul 27, 2023Updated 3 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- reflect api without runtime reflect.Value cost☆828Mar 22, 2025Updated last year
- Golang implementation of Radix trees☆946Jul 6, 2024Updated 2 years ago
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- ASCII table in golang☆4,821Updated this week
- TOML parser for Golang with reflection.☆5,027Aug 18, 2026Updated 2 months ago
- Go library for detecting and expanding the user's home directory without cgo.☆1,417Mar 21, 2024Updated 2 years ago
- A modern text/numeric/geo-spatial/vector indexing library for go☆11,245Oct 14, 2026Updated 2 weeks ago