concurrency utilities
☆304Aug 9, 2019Updated 7 years ago
Alternatives and similar repositories for concurrent
Users that are interested in concurrent are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- reflect api without runtime reflect.Value cost☆828Mar 22, 2025Updated last year
- logr implementation against the stdlib log package☆36Jul 14, 2022Updated 4 years ago
- pratt parser framework☆68Sep 14, 2018Updated 8 years ago
- The Snappy compression format in the Go programming language.☆1,573Jul 16, 2026Updated 3 months ago
- ☆15Jan 24, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A high-performance 100% compatible drop-in replacement of "encoding/json"☆13,855May 27, 2024Updated 2 years ago
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- [Deprecated] Protocol Buffers for Go with Gadgets☆5,654Jul 27, 2023Updated 3 years ago
- Go library for decoding generic map values into native Go structures and vice versa.☆8,011Jun 25, 2024Updated 2 years ago
- json reference for golang☆20Oct 9, 2026Updated 3 weeks ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- development tools☆46Aug 28, 2018Updated 8 years ago
- idiomatic codec and rpc lib for msgpack, cbor, json, etc. msgpack.org[Go]☆1,966Sep 2, 2026Updated last month
- a thread-safe concurrent map for go☆4,523May 22, 2024Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A simple interface wrapper around a Go channel.☆321Nov 3, 2020Updated 5 years ago
- Partial port of Python difflib package to Go☆429May 30, 2023Updated 3 years ago
- ☆23Nov 25, 2022Updated 3 years ago
- Selected Go-internal packages factored out from the standard library☆993Oct 5, 2026Updated 3 weeks ago
- Implements a deep pretty printer for Go data structures to aid in debugging☆6,425Apr 6, 2024Updated 2 years ago
- A cache library for Go with zero GC overhead.☆5,412Oct 6, 2026Updated 3 weeks ago
- Wrapper types for sync/atomic which enforce atomic access☆1,458Oct 20, 2026Updated last week
- Miscellaneous functions for formatting text☆96Jul 26, 2024Updated 2 years ago
- Fast JSON serializer for golang.☆4,916Mar 14, 2026Updated 7 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- LevelDB key/value database in Go.☆6,316May 14, 2024Updated 2 years ago
- go-querystring is Go library for encoding structs into URL query strings.☆2,144Aug 20, 2026Updated 2 months ago
- Fast event-loop networking for Go☆6,037May 19, 2026Updated 5 months ago
- A Go blocking leaky-bucket rate limit implementation☆4,724May 1, 2024Updated 2 years ago
- Go package providing information about the number of CPUs in the system☆34Updated this week
- Package errc simplifies error and defer handling.☆78Nov 8, 2017Updated 8 years ago
- ☆927Jul 23, 2026Updated 3 months ago
- Fast, efficient, and scalable distributed map/reduce system, DAG execution, in memory or on disk, written in pure Go, runs standalone or …☆3,570Oct 20, 2026Updated last week
- Leveled execution logs for Go☆3,597Apr 29, 2025Updated last year
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- A goroutine pool for Go☆4,021Mar 9, 2023Updated 3 years ago
- OpenTracing API for Go. 🛑 This library is DEPRECATED! https://github.com/opentracing/specification/issues/163☆3,471Apr 21, 2023Updated 3 years ago
- Errwrap is a Go (golang) library for wrapping and querying errors.☆458Oct 15, 2026Updated 2 weeks ago
- Effective Computation of Things☆114Aug 15, 2019Updated 7 years ago
- Efficient cache for gigabytes of data written in Go.☆8,174Oct 12, 2026Updated 2 weeks ago
- Connection multiplexer for GoLang: serve different services on the same port!☆2,771Jun 8, 2026Updated 4 months ago
- Fast thread-safe inmemory cache for big number of entries in Go. Minimizes GC overhead☆2,373Jun 15, 2026Updated 4 months ago