Zero-dependency lightbox for images, video, iframes & custom renderers. Native View Transitions morph, WCAG 2.2 AA, hooks + plugins, controlled mode. Pure TypeScript, works everywhere.
☆48Jun 29, 2026Updated 4 months ago
Alternatives and similar repositories for pencere
Users that are interested in pencere are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Universal printer language SDK — 9 languages, 9 parsers, 63 cross-compilers. TSC, ZPL, EPL, ESC/POS, CPCL, DPL, SBPL, Star PRNT, IPL. Zer…☆76Apr 2, 2026Updated 7 months ago
- Zero-dependency barcode & QR code SVG, PNG generator. 40+ formats, styled QR codes, tree-shakeable. Pure TypeScript.☆495Updated this week
- Collection of fully-typed tools to work in back-end with ease. (WIP)☆14Jun 1, 2026Updated 5 months ago
- Type-safe SQL query builder. Zero dependencies, AST-first, hookable, tree-shakeable. Pure TypeScript.☆127Aug 21, 2026Updated 2 months ago
- One command to lint, format check and type check your project, and keep a monorepo consistent. uncheck runs the oxlint, oxfmt, tsc and sh…☆39Updated this week
- End-to-end encrypted email - Proton Mail • AdSpecial offer: 40% Off Yearly / 80% Off First Month. All Proton services are open source and independently audited for security.
- OpenTelemetry package for AdonisJS☆15Updated this week
- 🧰 Universal, type-safe database adapter layer with a unified API for Drizzle, Prisma, Kysely, Knex, MongoDB, Sumak and in-memory backend…☆61Oct 30, 2026Updated 2 weeks ago
- Zero-dependency spreadsheet engine. Read & write XLSX, CSV, ODS. Pure TypeScript, works everywhere.☆2,260Oct 26, 2026Updated 2 weeks ago
- JSZipp is a tiny, dependency-free ZIP reader and writer for modern browser apps.☆14Jun 17, 2026Updated 4 months ago
- Driver-based, zero-dependency, fetch-first TypeScript HTTP client. Hooks, retry, redirect security, RFC 9111 cache, RFC 6265 cookies, Ide…☆79May 3, 2026Updated 6 months ago
- An Astro integration that adds a Webfinger file to your site, allowing others to discover your Mastodon profile from your own domain☆14Mar 9, 2023Updated 3 years ago
- ☆46Updated this week
- One unified API for 18 live-chat & customer-support widgets. Zero deps, tree-shakeable, SSR-safe, CSP-aware, strict TypeScript.☆42Apr 16, 2026Updated 6 months ago
- Animated React components and blocks for Tailwind CSS and Motion. Install with the shadcn CLI.☆40Updated this week
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Lunr integration for Astro☆17May 14, 2022Updated 4 years ago
- Zero-dep, tree-shakeable Web Audio library with synthesised UI presets, buses + ducking, polyphony cap, throttle, jitter, fades, pan, spr…☆27Apr 30, 2026Updated 6 months ago
- Experimental integration with Nuxt + Tailwind CSS v4.0☆37Apr 19, 2026Updated 6 months ago
- Stripe-style Idempotency-Key middleware for Hono with KV/D1/Memory stores☆14Nov 5, 2026Updated last week
- A suite of UI components for the SolidJS Lightning framework☆14Sep 26, 2025Updated last year
- A plugin for creating hierarchical navigation in Astro projects. Supports breadcrumbs too!☆18Jun 4, 2023Updated 3 years ago
- A lightweight analytics platform built on Upstash Redis, providing event tracking, session management, feature flags, and A/B testing wit…☆17May 25, 2026Updated 5 months ago
- One unified email API across 18 providers (SMTP, Resend, SES, Postmark, SendGrid, Mailgun, …). Zero deps, RFC 8058 + DKIM ready, edge-fir…☆297Sep 2, 2026Updated 2 months ago
- Open-source customer messaging for teams with many products: e-mail, live chat and in-app conversations in one inbox, plus newsletters, c…☆29Updated this week
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Styles, components, and tooling config for use in *.astro.build websites☆19Jul 13, 2026Updated 3 months ago
- A Nuxt module aimed to simplify the use of WebSockets.☆21Jun 28, 2025Updated last year
- A collection of utility functions.☆22Updated this week
- Pure-TypeScript Redis / Valkey wire-protocol driver. Runs unchanged on Node.js + Bun, AOT-compiles to a native binary via Perry (LLVM).☆21May 11, 2026Updated 6 months ago
- ☆10May 22, 2024Updated 2 years ago
- Astro UnoCSS integration☆20Feb 18, 2023Updated 3 years ago
- Self-hosted message queue for Deno Deploy☆38Dec 15, 2025Updated 10 months ago
- Dead-simple Vite SSR library☆21Apr 16, 2023Updated 3 years ago
- A file-based routing framework with Cloudflare Dynamic Workers☆125May 8, 2026Updated 6 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Transparent comparisons between schema validation libraries☆60Updated this week
- Bringing Mantine and Tailwind CSS together with ease.☆19Sep 29, 2024Updated 2 years ago
- A davinci type of application with adobe fusion☆13Updated this week
- Try-catch Replacement for JavaScript☆12Mar 31, 2025Updated last year
- Digging through logs is not observability. It's hope — wide events, structured errors, TypeScript-first, every runtime.☆1,937Updated this week
- Benchmarks between languages & js runtimes☆12Apr 24, 2024Updated 2 years ago
- 🦊 Logixlysia is a logger for ElysiaJS☆276Updated this week
Are these results useful?