One command to lint, format check and type check your project, and keep a monorepo consistent. uncheck runs the oxlint, oxfmt, tsc and sherif you installed, so you, your git hooks and your coding agents all run the same check.
☆39Nov 4, 2026Updated this week
Alternatives and similar repositories for uncheck
Users that are interested in uncheck are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Collection of fully-typed tools to work in back-end with ease. (WIP)☆14Jun 1, 2026Updated 5 months ago
- proposals for framework-agnostic JavaScript servers built on the Fetch API☆20Oct 24, 2026Updated 2 weeks ago
- AI chat, in your browser.☆17Sep 4, 2026Updated 2 months ago
- ☆21Updated this week
- this repo is along with my tutorial blog for orpc + effect☆10Jun 3, 2025Updated last year
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- npkill for Next.js — nuke bloated .next folders and reinstall a fresh instance. Monorepo & pnpm aware.☆14Jul 29, 2026Updated 3 months ago
- ☆15Updated this week
- Zero-dependency lightbox for images, video, iframes & custom renderers. Native View Transitions morph, WCAG 2.2 AA, hooks + plugins, cont…☆48Jun 29, 2026Updated 4 months ago
- ☆11Feb 26, 2026Updated 8 months ago
- Drizzle ORM adapter for CASL v7 - generate Drizzle where inputs from CASL abilities☆22Aug 3, 2026Updated 3 months ago
- The fastest way to create a Nitro app.☆19Oct 30, 2026Updated last week
- pattern matching for typescript 🤝 zod, valibot, arktype☆33May 8, 2026Updated 5 months ago
- Tiny when-clause expression evaluator with full type-safty☆38Apr 23, 2026Updated 6 months ago
- Fix TypeScript Declarations for default CJS exports☆15Mar 23, 2025Updated last year
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- A powerful TypeScript fuzzy search library with intelligent scoring, exact match prioritization, and automatic field detection for any ob…☆20Updated this week
- ORM, but better☆385Updated this week
- Tooling to visualize React Server Components vs Client Components boundaries in Next.js App Router☆129Sep 5, 2026Updated 2 months ago
- Open-source customer messaging for teams with many products: e-mail, live chat and in-app conversations in one inbox, plus newsletters, c…☆27Updated this week
- Catch the AI slop your agents ship.☆23Updated this week
- Accessible, unstyled coach mark component in React.☆47Oct 31, 2026Updated last week
- cizgile — Zero-dependency URL slug engine. RFC 3986/3987 slugs, transliteration for 7 scripts, Unicode slugs, IRI ↔ URI, percent-encoding…☆122Oct 20, 2026Updated 2 weeks ago
- The open-source platform for Cambridge AS & A-Level students to annotate, organize, and master past papers questions.☆18Mar 3, 2026Updated 8 months ago
- A demo of modern-monaco (by @ije) with Server Side rendering.☆26Sep 6, 2025Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Centralized repo for our CI/CD github actions workflows.☆12Feb 26, 2026Updated 8 months ago
- Tanstack Start (as SSR Frontend) + Hono (as API) https://tanstack-start-ssr-hono.onrender.com☆26Feb 5, 2025Updated last year
- Type-driven finite state machines☆47Sep 10, 2025Updated last year
- A library for converting, formatting and parsing CSS colours.☆25Updated this week
- Segment-level, human-first translation for markdown documentation☆33Updated this week
- Authentication and Access Control for any React app☆22Aug 26, 2026Updated 2 months ago
- monorepo for swift apps and packages☆10Dec 19, 2025Updated 10 months ago
- A Nest.js Boilerplate Kit designed to streamline the development process and accelerate the creation of modern web applications with pre-…☆10Jun 19, 2024Updated 2 years ago
- Nitro Vue Server☆11May 22, 2025Updated last year
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- A theme provider for React☆61Updated this week
- Beautiful dev-server error pages that live update. ✨☆110Updated this week
- Saas.js is a collection of utilities and components for building modern SaaS products.☆46Aug 18, 2026Updated 2 months ago
- Driver-based, zero-dependency, fetch-first TypeScript HTTP client. Hooks, retry, redirect security, RFC 9111 cache, RFC 6265 cookies, Ide…☆79May 3, 2026Updated 6 months ago
- Type-Safe Errors for JS & TypeScript☆15Jul 29, 2025Updated last year
- Unofficial airbnb api using Python3, Flask, BeautifulSoup, and Selenium to retrieve data off of the airbnb site☆15Dec 8, 2022Updated 3 years ago
- The best deep cleaning tool for desktop☆13Jan 6, 2026Updated 10 months ago