The fastest end-to-end type-safe RPC framework for TypeScript β compiled pipelines, single package, every runtime
β35Apr 27, 2026Updated 6 months ago
Alternatives and similar repositories for silgi
Users that are interested in silgi are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- π§° Universal, type-safe database adapter layer with a unified API for Drizzle, Prisma, Kysely, Knex, MongoDB, Sumak and in-memory backendβ¦β61Oct 30, 2026Updated 2 weeks ago
- Zero-dep, tree-shakeable Web Audio library with synthesised UI presets, buses + ducking, polyphony cap, throttle, jitter, fades, pan, sprβ¦β27Apr 30, 2026Updated 6 months ago
- Type-first routes for h3 v2 β validated params/body/query/response, a typed fetch client, and OpenAPI 3.1 β for plain h3 and nitro v3β11Sep 25, 2026Updated last month
- A status page that keeps beating when your server does not β one Cloudflare Worker, or one container you own. Astro, a probe a minute, D1β¦β39Aug 20, 2026Updated 2 months ago
- Use PartyKit π with Nuxt πβ12Dec 30, 2024Updated last year
- Managed hosting for WordPress and PHP on Cloudways β’ AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Driver-based, zero-dependency, fetch-first TypeScript HTTP client. Hooks, retry, redirect security, RFC 9111 cache, RFC 6265 cookies, Ideβ¦β79May 3, 2026Updated 6 months ago
- WebSockets solution for Nuxtβ12Apr 12, 2023Updated 3 years ago
- A Nuxt module aimed to simplify the use of WebSockets.β21Jun 28, 2025Updated last year
- A standalone Nitro module that integrates GraphQL servers into any Nitro application with automatic type generation, file watching, andβ¦β128Mar 18, 2026Updated 7 months ago
- Welcome to Nuxt Nitro Chat! π This Nuxt app uses experimental web sockets for real-time group chat in Nuxt.js. π¬β¨β40Aug 2, 2024Updated 2 years ago
- Tiny local-first hybrid search for docs and TypeScript. Up to 30% better recall plus optional cloud integrations.β24Oct 8, 2026Updated last month
- π€ Schema validation for h3 using Valibotβ78Nov 27, 2025Updated 11 months ago
- Annotate functions as pure for Rollup, Vite, esbuild, and rspackβ13Dec 15, 2025Updated 10 months ago
- Type-safe SQL query builder. Zero dependencies, AST-first, hookable, tree-shakeable. Pure TypeScript.β127Aug 21, 2026Updated 2 months ago
- Managed hosting for WordPress and PHP on Cloudways β’ AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A fetch client you compose β typed from your OpenAPI schema, no generated client codeβ103Updated this week
- π‘ Vue.js navigation guards, redefined !β21Jul 22, 2022Updated 4 years ago
- Generic environment runner for JavaScript runtime.β48Updated this week
- Open-source, self-hosted push notification service built with Vite, Vue 3 & Nitro.β340Apr 22, 2026Updated 6 months ago
- ποΈ Best practice Nitro Starter with full Vitest coverageβ24Nov 20, 2024Updated last year
- π Get the same key for the same sequence of values!β17Updated this week
- One unified email API across 18 providers (SMTP, Resend, SES, Postmark, SendGrid, Mailgun, β¦). Zero deps, RFC 8058 + DKIM ready, edge-firβ¦β297Sep 2, 2026Updated 2 months ago
- Agents for any host, composed with server primitives through one Vite plugin.β31Updated this week
- A simple Raycast application to monitor PageSpeed Insights.β12Jul 17, 2024Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer β’ AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A Small nuxt module to go server-first, client-maybeβ10Feb 2, 2024Updated 2 years ago
- Opinionated Nuxt starter with i18n support. Currently with experimental v4 enabledβ15Aug 26, 2024Updated 2 years ago
- A super simple window switcher for macOSβ13Sep 20, 2026Updated last month
- A real-time demo showcasing WebSockets to reactively update multiple states across different browsers/devices.β24Jan 22, 2025Updated last year
- π§ͺ Test Nitro apps with Vitest β development mode, production builds, and Cloudflare bindingsβ113Nov 2, 2026Updated last week
- A collection of my personal experimental Nuxt modules.β14Oct 27, 2026Updated 2 weeks ago
- Type-safe OpenAPI clients with MCP server for AI-driven API explorationβ19Nov 4, 2025Updated last year
- Zero-dependency barcode & QR code SVG, PNG generator. 40+ formats, styled QR codes, tree-shakeable. Pure TypeScript.β494Updated this week
- β10Jan 22, 2026Updated 9 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer β’ AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Embed & Showcase your projects on websitesβ17Jun 30, 2022Updated 4 years ago
- Build Schema.org graphs for JavaScript Runtimes (Browser, Node, etc). Improve your sites SEO with quick and easy Rich Results.β16Sep 3, 2023Updated 3 years ago
- ry stands for route yes: an AI router for 404s, powered by Cloudflare Clefβ13Oct 4, 2026Updated last month
- A typed fold over object contributions: build an object piece by piece, know its exact shape at every step, and prove when it is completeβ¦β16Sep 24, 2026Updated last month
- A lightweight utility library for managing permission bitmasks with groups and access levelsβ14Oct 22, 2026Updated 3 weeks ago
- Universal TypeScript extension for all popular toolchains.β13Updated this week
- A unified library to send emails - Choose your own email providerβ103Jun 5, 2025Updated last year
Are these results useful?