Universal printer language SDK — 9 languages, 9 parsers, 63 cross-compilers. TSC, ZPL, EPL, ESC/POS, CPCL, DPL, SBPL, Star PRNT, IPL. Zero dependencies. Pure TypeScript.
☆72Apr 2, 2026Updated 6 months ago
Alternatives and similar repositories for portakal
Users that are interested in portakal are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Zero-dependency barcode & QR code SVG, PNG generator. 40+ formats, styled QR codes, tree-shakeable. Pure TypeScript.☆488Oct 15, 2026Updated 2 weeks ago
- One unified API for 18 live-chat & customer-support widgets. Zero deps, tree-shakeable, SSR-safe, CSP-aware, strict TypeScript.☆40Apr 16, 2026Updated 6 months ago
- Zero-dependency lightbox for images, video, iframes & custom renderers. Native View Transitions morph, WCAG 2.2 AA, hooks + plugins, cont…☆48Jun 29, 2026Updated 4 months ago
- Type-safe SQL query builder. Zero dependencies, AST-first, hookable, tree-shakeable. Pure TypeScript.☆127Aug 21, 2026Updated 2 months ago
- One unified email API across 18 providers (SMTP, Resend, SES, Postmark, SendGrid, Mailgun, …). Zero deps, RFC 8058 + DKIM ready, edge-fir…☆296Sep 2, 2026Updated last month
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Driver-based, zero-dependency, fetch-first TypeScript HTTP client. Hooks, retry, redirect security, RFC 9111 cache, RFC 6265 cookies, Ide…☆79May 3, 2026Updated 5 months ago
- Wrapper over enquirer with better support for testing☆34Sep 7, 2026Updated last month
- Zero-dependency spreadsheet engine. Read & write XLSX, CSV, ODS. Pure TypeScript, works everywhere.☆2,250Updated this week
- A managed deferred queue to run async operations in the background☆103Dec 12, 2025Updated 10 months ago
- cizgile — Zero-dependency URL slug engine. RFC 3986/3987 slugs, transliteration for 7 scripts, Unicode slugs, IRI ↔ URI, percent-encoding…☆122Oct 20, 2026Updated last week
- Cloudflare Workers tracing spans for Drizzle ORM, for any driver☆17Updated this week
- ☆10Jan 22, 2026Updated 9 months ago
- A modern, open-source Slack-like chat application that can be self-hosted with just two environment variables.☆11Feb 10, 2026Updated 8 months ago
- Triplit Collection for TanStack DB☆13Nov 26, 2025Updated 11 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Alternative JSON.stringify function with sorted keys, so the output is stable.☆17Aug 18, 2025Updated last year
- ☆20Apr 8, 2024Updated 2 years ago
- See requests in the terminal. Get more detail with the panel. Nitrojs☆34Dec 5, 2024Updated last year
- Open-source BullMQ dashboard — modern alternative to bull-board. 13 framework adapters, FlowProducer DAGs, schedulers, macOS app, Docker …☆454Jun 1, 2026Updated 4 months ago
- A skill that helps AI agents write better docs, with support of Comark components.☆38Oct 2, 2026Updated 3 weeks ago
- An agent skill to add preview deployments to your Cloudflare apps using GitHub Actions workflows and the GitHub Deployments API.☆16Updated this week
- A lightweight analytics platform built on Upstash Redis, providing event tracking, session management, feature flags, and A/B testing wit…☆17May 25, 2026Updated 5 months ago
- A declarative ZPL library.☆12Sep 9, 2024Updated 2 years ago
- ☆79Oct 16, 2026Updated 2 weeks ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- ☆23Updated this week
- A blazingly fast, opinionated, native TypeScript CMS. Designed for Perry AOT, runs on Node and Bun.☆27Jul 29, 2026Updated 3 months ago
- Massimo is an API SDK client and CLI tool for creating clients for remote OpenAPI or GraphQL APIs☆204Updated this week
- macOS-inspired controls, built for Vue.☆34Aug 13, 2026Updated 2 months ago
- This app provides a WhatsApp web interface for businesses to communicate with customers. It automates responses through a flow builder or…☆17Sep 28, 2024Updated 2 years ago
- Tiny Durable Workflow SDK in Typescript☆32Sep 17, 2026Updated last month
- ☆27Jun 6, 2025Updated last year
- Starter template for using Better Auth with Tanstack Start - includes Drizzle ORM and sqlite DB.☆22Nov 6, 2025Updated 11 months ago
- A Medusa's 1.x plugin to implement easily OTP☆12Mar 5, 2025Updated last year
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- A JavaScript implementation of the Simple Color Palette format — a minimal JSON-based file format for defining color palettes☆15Oct 19, 2025Updated last year
- Tiptap editor demo made with Nuxt, Nitro and y-crossws for live collaboration.☆77Nov 21, 2024Updated last year
- BOMfu is a collaborative writing tool for bill of materials (BOM).☆13Jul 24, 2013Updated 13 years ago
- ☆33Mar 14, 2023Updated 3 years ago
- ☆20Updated this week
- A super tiny work queue☆36Nov 30, 2019Updated 6 years ago
- ☆10Nov 14, 2025Updated 11 months ago