An RFC5297-compliant C implementation of AES-SIV
☆21Oct 15, 2020Updated 6 years ago
Alternatives and similar repositories for libaes_siv
Users that are interested in libaes_siv are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- ☆10Dec 24, 2018Updated 7 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- like ChaCha, but 64-bit instead of 32-bit thanks to BLAKE2b's permutation☆16Apr 8, 2017Updated 9 years ago
- IETF I-D for Network Time Security☆12Mar 25, 2020Updated 6 years ago
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- Slides and other working group materials☆11Feb 5, 2024Updated 2 years ago
- [work in progress] Python framework for supporting cryptographic game-hopping proofs☆13Oct 19, 2022Updated 4 years ago
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆53Apr 24, 2026Updated 6 months ago
- Deterministic/nonce-reuse resistant authenticated encryption scheme using XChaCha20, implemented on libsodium.☆31Aug 5, 2024Updated 2 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Drop In USB CDC ACM core for iCE40 FPGA☆37Sep 5, 2021Updated 5 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- ☆12May 7, 2021Updated 5 years ago
- Experimental High Assurance Cryptographic Library☆21Feb 1, 2016Updated 10 years ago
- A history of PGP-related vulnerabilities☆24Jan 13, 2026Updated 9 months ago
- A BibTeX collection on Isogeny-based Cryptography☆18Jan 20, 2023Updated 3 years ago
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- The anonymous credentials zoo☆16Mar 17, 2021Updated 5 years ago
- NTS proof of concept in Python☆10Jan 1, 2023Updated 3 years ago
- Solution to harden TLS security by storing private keys and delegating operations to the Trused Execution Environment☆13Oct 10, 2022Updated 4 years ago
- Efficient Anonymous Tokens with Private Metadata Bit☆16Mar 7, 2023Updated 3 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- LLVM backend for OpenRISC 1000☆12Oct 3, 2012Updated 14 years ago
- Authenticated Encryption Based on the Masked Even-Mansour (MEM) Construction☆28Apr 20, 2018Updated 8 years ago
- Hardware implementation of the poly1305 message authentication function.☆12Apr 3, 2025Updated last year
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- BLST-Verification☆23Apr 22, 2026Updated 6 months ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- ABE GPSW scheme using BLS pairing implemented in Rust.☆17May 23, 2023Updated 3 years ago
- A place to discuss Private Measurement☆14Aug 8, 2023Updated 3 years ago
- ☆18Oct 30, 2023Updated 3 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- ☆11Jul 29, 2020Updated 6 years ago
- puppet module for managing Microsoft .NET☆12Updated this week
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- A small and easy to use HPKE implementation in Go.☆20Sep 17, 2026Updated last month
- Simple 6502 system on a ULX3S FPGA board☆20Feb 26, 2020Updated 6 years ago