Package xdp provides access to Linux userspace XDP sockets (AF_XDP). MIT Licensed.
☆40Mar 7, 2019Updated 7 years ago
Alternatives and similar repositories for xdp
Users that are interested in xdp are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Package tftp implements a TFTP server, as described in RFC 1350. MIT Licensed.☆11Jun 19, 2015Updated 11 years ago
- Package block enables programmatic access to block devices. MIT Licensed.☆22Oct 25, 2018Updated 7 years ago
- Package aoe implements an ATA over Ethernet server, as described in the AoEr11 specification. MIT Licensed.☆13Nov 7, 2016Updated 9 years ago
- Generic tool to inspect BPF maps☆45Jan 10, 2022Updated 4 years ago
- Smart Go module dependency inspection and pruning.☆19Jun 11, 2020Updated 6 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Package kobject provides access to Linux kobject userspace events. MIT Licensed.☆23Mar 4, 2024Updated 2 years ago
- Package vxlan implements marshaling and unmarshaling of Virtual eXtensible Local Area Network (VXLAN) frames, as described in RFC 7348. …☆12Apr 20, 2016Updated 10 years ago
- Go packages for adding delay and buffering to network connections☆16Sep 16, 2019Updated 7 years ago
- Package raw enables reading and writing data at the device driver level for a network interface. MIT Licensed.☆424Feb 21, 2022Updated 4 years ago
- Easy to use native encoding/binary.ByteOrder☆31Sep 17, 2026Updated 3 weeks ago
- Package genetlink implements generic netlink interactions and data types. MIT Licensed.☆66Jun 3, 2026Updated 4 months ago
- Linux kernel utilities for Go.☆17Jun 18, 2019Updated 7 years ago
- NUMA bindings for Go, requires libnuma.☆26Nov 18, 2019Updated 6 years ago
- eBPF package for Go☆28May 29, 2019Updated 7 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Package alg provides access to Linux AF_ALG sockets for communication with the Linux kernel crypto API. MIT Licensed.☆17May 11, 2021Updated 5 years ago
- Package socket provides a low-level network connection type which integrates with Go's runtime network poller to provide asynchronous I/O…☆98Oct 1, 2026Updated last week
- Package ethernet implements marshaling and unmarshaling of IEEE 802.3 Ethernet II frames and IEEE 802.1Q VLAN tags. MIT Licensed.☆288Feb 21, 2022Updated 4 years ago
- A collection of fast, general-purpose immutable data structures for Go.☆20Apr 17, 2022Updated 4 years ago
- Package taskstats provides access to Linux's taskstats interface, for sending per-task and per-process statistics from the kernel to user…☆66Jul 2, 2026Updated 3 months ago
- Package rtnetlink provides low-level access to the Linux rtnetlink API. MIT Licensed.☆173Sep 9, 2026Updated last month
- Package ndp implements the Neighbor Discovery Protocol, as described in RFC 4861. MIT Licensed.☆237May 24, 2026Updated 4 months ago
- Plot pixels on a 320x200 256c canvas☆11Updated this week
- A toy tool that leverages the super powers of XDP to bring in-kernel IP filtering☆105Aug 24, 2020Updated 6 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Golang binding for netmap https://github.com/luigirizzo/netmap☆29Feb 3, 2019Updated 7 years ago
- github.com/cznic/fileutil has moved to modernc.org/fileutil☆16Nov 22, 2018Updated 7 years ago
- ☆12Jun 7, 2022Updated 4 years ago
- build simple single-layer containers and upload them to a repository.☆37May 4, 2023Updated 3 years ago
- eBPF Utilities, Maps, and more☆254Mar 15, 2023Updated 3 years ago
- Thread based NFVi on DPDK☆27Feb 3, 2018Updated 8 years ago
- Cloud ready L4 TCP proxy with first-class support for dynamic listeners☆44Apr 21, 2025Updated last year
- simple data streams for go☆32Aug 25, 2022Updated 4 years ago
- traffic control in pure go - it allows to read and alter queues, filters and classes☆532Sep 24, 2026Updated 2 weeks ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- mysocketctl command line tool for mysocket.io☆14Nov 9, 2022Updated 3 years ago
- An AVX/AVX2/x64/pure-Go implementation of the ChaCha20 stream cipher for Golang. [Deprecated].☆11Mar 15, 2018Updated 8 years ago
- Opening and operating on shared memory devices☆16Apr 17, 2014Updated 12 years ago
- QEMU Machine Protocol implementation for the Golang☆12Feb 1, 2023Updated 3 years ago
- Package lldp implements marshaling and unmarshaling of IEEE 802.1AB Link Layer Discovery Protocol frames. MIT Licensed.☆35Sep 15, 2015Updated 11 years ago
- Compact tries for fixed-width keys☆28Jun 4, 2018Updated 8 years ago
- A lightweight user land implementation of the UDP/IPv4 stack designed to plug into the netmap framework. The 's' stands for speed.☆10Dec 11, 2024Updated last year