Package socket provides a low-level network connection type which integrates with Go's runtime network poller to provide asynchronous I/O and deadline support. MIT Licensed.
☆101Oct 12, 2026Updated 2 weeks ago
Alternatives and similar repositories for socket
Users that are interested in socket are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Package packet provides access to Linux packet sockets (AF_PACKET). MIT Licensed.☆108Sep 12, 2026Updated last month
- Package networkd enables control of systemd-networkd using D-Bus. MIT Licensed.☆16Aug 12, 2023Updated 3 years ago
- Package genetlink implements generic netlink interactions and data types. MIT Licensed.☆67Jun 3, 2026Updated 4 months ago
- Exposes batch message receives (recvmmsg)☆14Sep 11, 2026Updated last month
- Package icmpx provides low-level ICMPv4 (IPPROTO_ICMP) and ICMPv6 (IPPROTO_ICMPV6) raw socket support for Linux. MIT Licensed.☆31Sep 7, 2023Updated 3 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Package sdnotify implements systemd readiness notifications as described in https://www.freedesktop.org/software/systemd/man/sd_notify.ht…☆46Apr 6, 2022Updated 4 years ago
- Package ethtool allows control of the Linux ethtool generic netlink interface. MIT Licensed.☆76Aug 1, 2026Updated 2 months ago
- Package rfc4193 implements Unique Local IPv6 Unicast Address prefix generation, as described in RFC 4193. MIT Licensed.☆13May 12, 2020Updated 6 years ago
- Package xdp provides access to Linux userspace XDP sockets (AF_XDP). MIT Licensed.☆40Mar 7, 2019Updated 7 years ago
- Easy to use native encoding/binary.ByteOrder☆31Sep 17, 2026Updated last month
- Package wifiqr implements support for generating WiFi QR codes. MIT Licensed.☆14Oct 1, 2024Updated 2 years ago
- Package netlink provides low-level access to Linux netlink sockets (AF_NETLINK). MIT Licensed.☆1,085Oct 14, 2026Updated 2 weeks ago
- Local file-based atomic cache manager☆48Oct 20, 2026Updated last week
- Golang port of the official seashells client☆16Jul 27, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Package block enables programmatic access to block devices. MIT Licensed.☆22Oct 25, 2018Updated 8 years ago
- Always wanted to write performant P4 based networking application in Go but don't know where to start? Then this is the place to get to. …☆18Feb 24, 2023Updated 3 years ago
- Command wgipamd implements an IP Address Management (IPAM) daemon for dynamic IP address assignment to WireGuard peers, using the wg-dyna…☆30Jan 2, 2020Updated 6 years ago
- Package rtnetlink provides low-level access to the Linux rtnetlink API. MIT Licensed.☆174Oct 12, 2026Updated 2 weeks ago
- gobgp library - NodeJS client for gobgpd☆19Oct 2, 2025Updated last year
- 谈谈Go泛型 - GopherChina 2023 大会分享☆25Jun 11, 2023Updated 3 years ago
- Package ethernet implements marshaling and unmarshaling of IEEE 802.3 Ethernet II frames and IEEE 802.1Q VLAN tags. MIT Licensed.☆289Feb 21, 2022Updated 4 years ago
- Go library for interacting with AF_PACKET sockets with socket timestamp support☆21May 10, 2022Updated 4 years ago
- a lite version of rpcx☆15Sep 7, 2021Updated 5 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Package wgdynamic implements a client and server for the the wg-dynamic protocol. MIT Licensed.☆13Feb 25, 2023Updated 3 years ago
- Package vsock provides access to Linux VM sockets (AF_VSOCK) for communication between a hypervisor and its virtual machines. MIT Licens…☆396Oct 15, 2026Updated 2 weeks ago
- ☆26Mar 19, 2022Updated 4 years ago
- Package ndp implements the Neighbor Discovery Protocol, as described in RFC 4861. MIT Licensed.☆238Oct 16, 2026Updated last week
- 🚀 A real-time Golang runtime stats visualization profiler☆10Apr 16, 2024Updated 2 years ago
- A sub-RFC1928 SOCKS5 server implementation in Go with zero external dependencies.☆11Sep 5, 2023Updated 3 years ago
- Fastest and most efficient goroutine pool (experimental)☆141Oct 16, 2022Updated 4 years ago
- Extensions to Go's testing/iotest package☆12Feb 13, 2016Updated 10 years ago
- TFTP, HTTP library, and CLI server for serving iPXE binaries☆28Dec 2, 2025Updated 10 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- GO Fast xorshift* and xorshift+ implementation☆16May 2, 2020Updated 6 years ago
- Support for Unix domain sockets in Go HTTP clients☆85Sep 19, 2025Updated last year
- Package alg provides access to Linux AF_ALG sockets for communication with the Linux kernel crypto API. MIT Licensed.☆17May 11, 2021Updated 5 years ago
- A pure Go IPv6 Router Advertisement library and stand-alone daemon☆17Updated this week
- fastest goid☆16Mar 6, 2025Updated last year
- netcat using netstack userspace library and eBPF☆138Sep 20, 2021Updated 5 years ago
- Package raw enables reading and writing data at the device driver level for a network interface. MIT Licensed.☆423Feb 21, 2022Updated 4 years ago