Package raw enables reading and writing data at the device driver level for a network interface. MIT Licensed.
☆423Feb 21, 2022Updated 4 years ago
Alternatives and similar repositories for raw
Users that are interested in raw are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Package ethernet implements marshaling and unmarshaling of IEEE 802.3 Ethernet II frames and IEEE 802.1Q VLAN tags. MIT Licensed.☆289Feb 21, 2022Updated 4 years ago
- Package arp implements the ARP protocol, as described in RFC 826. MIT Licensed.☆391Sep 23, 2026Updated last month
- Package netlink provides low-level access to Linux netlink sockets (AF_NETLINK). MIT Licensed.☆1,085Oct 14, 2026Updated 2 weeks ago
- Package xdp provides access to Linux userspace XDP sockets (AF_XDP). MIT Licensed.☆40Mar 7, 2019Updated 7 years ago
- Provides packet processing capabilities for Go☆6,798Mar 19, 2025Updated last year
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Package dhcp6 implements a DHCPv6 server, as described in RFC 3315. MIT Licensed.☆80Feb 24, 2023Updated 3 years ago
- Package block enables programmatic access to block devices. MIT Licensed.☆22Oct 25, 2018Updated 8 years ago
- Package packet provides access to Linux packet sockets (AF_PACKET). MIT Licensed.☆108Sep 12, 2026Updated last month
- IPv4 and IPv6 userland network stack☆3,111Dec 10, 2019Updated 6 years ago
- Package ndp implements the Neighbor Discovery Protocol, as described in RFC 4861. MIT Licensed.☆238Oct 16, 2026Updated 2 weeks ago
- Linux networking in Go☆598Aug 8, 2020Updated 6 years ago
- Package genetlink implements generic netlink interactions and data types. MIT Licensed.☆67Jun 3, 2026Updated 4 months ago
- NFF-Go -Network Function Framework for GO (former YANFF)☆1,416Nov 22, 2022Updated 3 years ago
- BGP implemented in the Go Programming Language☆4,117Updated this week
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- A simple TUN/TAP library written in native Go.☆2,168Jul 30, 2024Updated 2 years ago
- Package vsock provides access to Linux VM sockets (AF_VSOCK) for communication between a hypervisor and its virtual machines. MIT Licens…☆396Oct 15, 2026Updated 2 weeks ago
- DHCP4 library written in Go.☆323Sep 9, 2019Updated 7 years ago
- Simple netlink library for go.☆3,321Updated this week
- Zero-copy sockets for Linux in Golang☆830Jul 7, 2020Updated 6 years ago
- A collection of small Go networking packages. MIT Licensed.☆27Apr 30, 2023Updated 3 years ago
- Package aoe implements an ATA over Ethernet server, as described in the AoEr11 specification. MIT Licensed.☆13Nov 7, 2016Updated 9 years ago
- eBPF Utilities, Maps, and more☆254Mar 15, 2023Updated 3 years ago
- HTTP Keyserver Protocol (HKP) handlers☆12Apr 25, 2018Updated 8 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Package tftp implements a TFTP server, as described in RFC 1350. MIT Licensed.☆11Jun 19, 2015Updated 11 years ago
- router7 is a small home internet router completely written in Go. It is implemented as a gokrazy appliance.☆2,772Jul 19, 2026Updated 3 months ago
- Library to work with eBPF programs from Go☆1,171Jul 2, 2026Updated 3 months ago
- xoshiro256** random number generator☆22May 7, 2018Updated 8 years ago
- Go bindings for dpdk (http://dpdk.org/).☆123May 7, 2016Updated 10 years ago
- Control TUN/TAP virtual network interfaces.☆93Apr 24, 2016Updated 10 years ago
- This repository contains a Go module to interact with Linux nftables (the iptables successor).☆1,373Jul 3, 2026Updated 3 months ago
- Recursive and authoritative DNS server in go, including DNSSEC and DNS-over-TLS☆1,601Jun 18, 2020Updated 6 years ago
- A fully Go userland with Linux bootloaders! u-root can create a one-binary root file system (initramfs) containing a busybox-like set of …☆3,082Updated this week
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- a small circular ring buffer library in go / golang☆189Mar 14, 2019Updated 7 years ago
- DHCPv6 and DHCPv4 packet library, client and server written in Go☆849Oct 14, 2026Updated 2 weeks ago
- DNS library in Go☆8,793Oct 1, 2026Updated 3 weeks ago
- Software sandbox for storage of sensitive information in memory.☆2,765May 8, 2026Updated 5 months ago
- Easy SSH servers in Golang☆4,183Jan 27, 2025Updated last year
- Package wgdynamic implements a client and server for the the wg-dynamic protocol. MIT Licensed.☆13Feb 25, 2023Updated 3 years ago
- Pure golang package for reading and writing xz-compressed files☆561Oct 10, 2026Updated 2 weeks ago